Jump to content

Shuttering in 6, 7, 8th gear?


Recommended Posts

Hello,  I have a 14 pinnacle,  mp8 with an mdrive.  It has a shutter in 6,7 and 8th gears while pulling. For the most part I don't notice it running empty.   Had mack garage look at it and determined it could be clutch,  so I had that changed,  no change?  Drive line looks good,  they want to change injectors next,  but I am having a hard time buying that,  there are no other indicators that injectors are bad?  Anyone else deal with this in their mack?  Thank you

Link to comment
Share on other sites

408000..  they looked at some things in the tranny when they had it out.   On a manual tranny you have splitters, I am wondering if there are high low and mid in that tranny and if there is something up with those middle gears? 

Link to comment
Share on other sites

No, this is fine for this thread. I’m just saying it’s more then likely the trans giving you issues. They arnt expected more then 500k if your lucky. 

Link to comment
Share on other sites

did the shop check the u-joints, and air ride height?  just curious? has the drive shaft been apart and put back together wrong?  I know you have a 12 spd, just curious..  jojo

Link to comment
Share on other sites

I understand, I guess I was thinking that in those gears you are pulling hard to get up to speed..  I hope you get this fixed soon... jojo

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...