Jump to content
  • 0
xXxMackDaddy

Automatic motor put on a manual transmission, Regen system removed/Deleted

Question

My employer had the automatic motor from one truck put on the manual transmission of another truck. I’m forced to drive it now. They also removed/deleted the def/Regen system.
 

Every time I start the truck the computer says the truck is in derate. To do the parked regen. I cannot since the system was removed. & a second screen says regen switch malfunction.
 

This truck has been to Red Head dozens of times. This time it came back with these warnings on the computer screen.

The loaded pulling power is reduced greatly. 5 mins+ to reach highway speed. Up hill loaded is hell.  Speed is not maintained. It slows to 10-30 kmph depending on the slope & length of the hill. This has been an ongoing problem for a long time. My employer does not believe me or chooses to ignore the problem. 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

firstly . there is no such thing as an automatic motor . further analysis is needed

Share this post


Link to post
Share on other sites
  • 0

He never even said it's a Mack.

Share this post


Link to post
Share on other sites
  • 0

He may be from down under so it may have to be translated into American

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, carlotpilot said:

firstly . there is no such thing as an automatic motor . further analysis is needed

Probably means Automated Motor you know with a Ca-puter running it.

Share this post


Link to post
Share on other sites
  • 0

I was thinking an engine from a truck with an automatic trans of some sort to a truck with a manual trans? There’s no telling.

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
On 11/28/2019 at 7:33 AM, 1965 said:

I was thinking an engine from a truck with an automatic trans of some sort to a truck with a manual trans? There’s no telling.

His description leads to a ECM with the sensors disabled and components removed and de-rating (limp mode).

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...