Jump to content

AMI 370 engine humming noise


Recommended Posts

I have a 2006 granite I purchased new in 2008 for local use only 54000 miles on truck. All of a sudden it started making a very noticeable humming noise at idle and oil had a smell like burnt plastic, I can't find the problem, removed fan belts no change,removed power steering pump same, oil spinner filter,air brake compressors same noise. replaced oil pump (found wear marks on release valve) now noise is not as loud but still there. Not in trans or clutch (same when clutch is pushed in) Afraid to keep running and have major problems.

I even had a mack tech look at it and he pretty much didn't have a clue

Anyone ever experienced this problem.

Thanks for any help

 

 

Link to post
Share on other sites

Got an asset 460 that smells with fresh oil in it always did  for some reason.    310.000 on it and it always smells with fresh oil but not like rubber   Have you cleaned the breather element?  Don’t know about the noise got a video of it.  Smellavision would be good   Couldn’t help myself

Link to post
Share on other sites

I know you said you pulled the belts however when this model first came out fan hub bearings were an issue for a time!  Can you tell which the direction the humm is coming from! ? If the bearings in the hub were bad you could stand mid rad and hear it at idle!

Link to post
Share on other sites

Hey I asked why my 98 E7 clanks so loud, drives me nuts, Mack shop said it sounds good, they can not even tell me what makes the clanking sound, I find it I will try to get rid of it. Truck runs great oil stays really clean just clanks.

Link to post
Share on other sites
4 hours ago, fjh said:

I know you said you pulled the belts however when this model first came out fan hub bearings were an issue for a time!  Can you tell which the direction the humm is coming from! ? If the bearings in the hub were bad you could stand mid rad and hear it at idle!

When you walk around around the truck sounds the same on both sides and front.

When I took air brake compressor off and made a plate to cover engine block it was actually louder. Anyone ever heard of any issues with the auxiliary shaft or timing gears.

18 hours ago, mrgumby said:

Does it have an electric fan clutch?

 

Link to post
Share on other sites
  • 7 months later...

I've done similar tests unhooking fan belt. Put broom handle against areas on engine engaged clutch no change Nothing seems to sound odd. Truck operates fine just has a strange noise

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...