Jump to content

Maxi torque problems


Recommended Posts

  • 7 years later...
2 hours ago, Dave G said:

My 06 Mac vision with a maxi torque 10 speed trans Does not want to stay in high range. We'll shift into high range but when you let off the accelerator it tries to shift itself back into low range and grinds.

Synchro or air cylinder? Maybe?

"Eagles may soar, but weasels don't get sucked into jet engines."

Link to comment
Share on other sites

6 minutes ago, doubleclutchinweasel said:

Synchro or air cylinder? Maybe?

not familiar with an '06, as a thought; if it were a bad synchro  would there not be a grinding rough shift. air cyl  having a crack on plunger ? which side gets more air- low or high to make a shift? 

Link to comment
Share on other sites

if it doesnt do it in 5th,, highly likely its in the back box.  synchro sliding clutch may have diamond shaped teeth by now..  Just for kicks, is the grinding strong in the shifter?   I ask because many guys use the gear shifter as an arm rest, which can mess the shift fork up..  good luck Jojo

Link to comment
Share on other sites

ideas are based on the R/ R  trans. have seen the plunger nut back off  not allowing a complete syncro shift. post was 3hrs ago; Dave G still around, could answer some questions such as + does the shift grind== is there an air leak in either range  etc

Link to comment
Share on other sites

1 hour ago, mechohaulic said:

ideas are based on the R/ R  trans. have seen the plunger nut back off  not allowing a complete syncro shift. post was 3hrs ago; Dave G still around, could answer some questions such as + does the shift grind== is there an air leak in either range  etc

Guys ! 12 speed!!!!  (1070)?

You likely have a broken shift rail ! The trans ! The other thing that commonly  happens is the snap ring in the split cylinder breaks !

Lift the lid off and look down inside there is a tapered shift rail it is likely broken!

 

Just saying!

  • Like 1
Link to comment
Share on other sites

2 minutes ago, fjh said:

Guys ! 12 speed!!!!  (1070)?

You likely have a broken shift rail ! The trans ! The other thing that commonly  happens is the snap ring in the split cylinder breaks !

Lift the lid off and look down inside there is a tapered shift rail it is likely broken!

 

Just saying!

I’m gonna go with this

Link to comment
Share on other sites

I'm going to have to pay more attention to the dates of the posts I guess!

I'd like to know how these old posts keep getting  recycled! It had zero replies  when I looked at it first! just getting old and senile I guess!😐

  • Like 1
  • Haha 1
Link to comment
Share on other sites

too me,,,, its easy to miss it, especially when I 'scroll' quickly...   so what do you think the issue is?  jojo

Edited by Joey Mack
I type poorly
Link to comment
Share on other sites

33 minutes ago, fjh said:

I'm going to have to pay more attention to the dates of the posts I guess!

I'd like to know how these old posts keep getting  recycled! It had zero replies  when I looked at it first! just getting old and senile I guess!😐

I figure somebody is looking through the old posts for a similar problem, hopefully with a solution attached.  And, if they don't find one, maybe they tag onto a post that is close and hope for an answer?

Might be better to just start a new thread for the exact problem.  Might catch more attention, and hopefully cause less confusion.

Anyway, I'm bettin' one of you guys can help the man out!

"Eagles may soar, but weasels don't get sucked into jet engines."

Link to comment
Share on other sites

46 minutes ago, Joey Mack said:

too me,,,, its easy to miss it, especially when I 'scroll' quickly...   so what do you think the issue is?  jojo

As stated ! Shift rail! pricey to impossible fix parts are scarce! PAI MABE! Fuller time!

Edited by fjh
Link to comment
Share on other sites

PAI, is still making these parts.. The shop I use locally, rebuilds tranny's and rear's with PAI parts.. I think Eaton parts are still available as well.. But I know that the Mack's are built with PAI..  I have had 4 done in the last year. jojo

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...