Jump to content

99 RD 688s running hot


Recommended Posts

Last couple of days has been warm. With a full load on, the temperature gage has been creeping into the red and the idiot light comes on. I have managed to get the temperature down pretty quickly but I would like tofind out what the problem is and fix it. Not overly mechanical here but getting better with every mile I spend in a Mack LOL

Link to comment
Share on other sites

1 hour ago, bts-4120 said:

radiator stopped up with bugs and dust?

Or the AC Condenser in front of the rad.

"OPERTUNITY IS MISSED BY MOST PEOPLE BECAUSE IT IS DRESSED IN OVERALLS AND LOOKS LIKE WORK"  Thomas Edison

 “Life’s journey is not to arrive at the grave safely, in a well preserved body, but rather to skid in sideways, totally worn out, shouting ‘Holy shit, what a ride!’

P.T.CHESHIRE

Link to comment
Share on other sites

  • 2 weeks later...

Any or all the above.......Top up coolant, clean the radiator, swap out the thermostat, check viscous fan by spinning (engine off) to confirm it has resistance, or unplug the A/C high pressure switch to manually turn engine fan on and off (switch is on right side close to top bolt of radiator support member). Last effort, have a radiator shop "rod out" plugged core or replace radiator.   

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...