Jump to content

MACKX

Puppy Poster
  • Posts

    21
  • Joined

  • Last visited

Everything posted by MACKX

  1. The switches are under the dash drivers side up above the throttle and brake pedal.... should be 3 pressure switches .... can’t remember what one does ,but one is to show the park brake is applied & one is low air. U can put a T in the low air switch port and add an additional switch to operate the buzzer , source an old green buzzer out of a DM or RB .... something of that sort and wire the second switch to operate the buzzer
  2. I’ll look in the morning if I get around a granite to get an idea on that engine brake relay location..... did you check the connector at the switch for the engine brake? Take the kick panel down on the passenger side and check the VECU module connections and make sure they arent rubbed and rotted from salt since it’s an old NYDOT truck. the lighting bolt isn’t on correct? The wiring to the cam sensor is good also ?
  3. If it’s a Bosch 7100 pump the overflow valve will cause extended crank times.... it’s on the top outside of the pump as John said earlier .... take it out and see if shakes like a rattle if it does it should be working ... you can take the end plug out and remove the spring and stretch it out to buy a little time before you get a new one if need be.... definitely check for air leaks also
  4. After checking the grounds that have been mentioned and the cam and crank sensors , check the connectors on the VECU in behind the passenger side kick panel.... make sure connections are good there and no rubbing of wires and check the connectors at the ECU , the coolant bottle isn’t leaking down into the connectors is it ?
  5. How many miles are on this engine? Are all the valves adjusted about the same.... as in you didn’t have to crank one to the end of threads to get adjustment correct? Were the lifters or the EUP lifters checked? The ceramic rollers break or the metal rollers score up and cause a miss that way, especially if you had broken valve train components
  6. Outside of checking for shorts in the throttle pedal wiring ...did you try taking the cruise control switch and the accel/decel switch out of the equation? Take the dash panel off that side and make sure the harness isn’t melted together on those 2 connectors
  7. 2003 was the ETechs last year..... 2002 was close to that so the kinks were almost worked out by then..... so I would take the 02 over the 99
  8. I think if it’s a VMAC eng timing is set to #6 with a 7100 Bosch I’ll have to look in the manual...... the cutout your seeing if for that timing sensor tool to see ...... hopefully Joey Mack chimes in here .... I’ve only done a couple where I had to set it up without marks being made and had the luxury of the timing tool being around from an old Mack dealer man
  9. Good call Jojo...... I have also done the same thing before to make the buzzer operational after the cluster takes a dump...always seems to be the air alarm but everything else works fine 😒..... just when I looked up the buzzer I used an RB690S vin lol that’s horrible the DOT officer is a dick and will probably hassle you if you don’t make the buzzer operational again......
  10. There is a thread that is in engine and transmission about this exact topic and you can browse it and see how much money and time your willing to spend on it ..... software and old E-Tech engine parts will be your friend
  11. I see what your saying now........ can’t honestly say Ive used a PAI thermostat , always use Mack thermostats, hopefully it sets up and holds , gotta do what you gotta do till you can buy a housing... can always try permatex aviation form a gasket also if the pitting isn’t really bad ... that has got me thru a couple pinches till I could get parts on customers trucks and equipment
  12. I’m assuming what you mean by the spacer ,you mean the thermostat seal.... that will go in the housing and the thermostat bodies will pilot inside the seal.....did you take out the old seals before attempting to install the new thermostats?
  13. First choice is the 03 CH with the ETech in it as Vmac3 said.... the bugs were worked out mostly by that last year of production .... next choice is the granite with the AMI .... if you do software updates , set of injectors and use some old ETech parts u can have a pretty decent running truck ,dodge those MP7s 🤮as long as u possibly can
  14. That’s what it’s all about on here .... helping each other out, learning new stuff and such from each other’s experiences.... glad u got them all in.... since they’re reconditioned I think you’d be ok but however myself I would have them all in the right holes so it all matches 😆 I’m just anal with things.... I even match the writing up on matched V-belts lol
  15. Yes that is true Mark... I am too lazy to call it silastic sealant lol
  16. Mack RTV part number is 342SX33
  17. Yes, check height then when you reinstall , put the seal on the liner with Mack RTV at the liner seat , I use Mack grey nothing else , other guys may have another RTV that works for them , I just use the Mack RTV
  18. The buttress bolts are 90 ft/lb make sure the long bolts go on the right side of the engine on bearings 2&3 by the aux drive your mains are 210 ft/lb, and Fjh is correct with the height they can be .022-.027 under the same head as long as they are in that spec range
  19. You used a load tester on the batteries to check them correct? And you disconnected them and checked each battery individually? If so, you have to check voltage at the starter to ensure your getting 12V at the starter then check for a voltage drop while cranking .... check your grounds also..... if voltage drop, voltage, and grounds are good then the starter is likely bad. Make sure the starter solenoid on the firewall isn’t corroded also. As for extended crank time what is the fuel pressure , are the filters good? And lastly ... check the cam and crank sensors.... they will cause extended crank time
  20. What is low side fuel pressure while cranking the engine? What happens if you pump the primer pump while trying to start the engine ? And lastly is it just a davco filter or does it have the davco plus another filter on the truck ?
×
×
  • Create New...