Jump to content
  • 0

RED SHUTDOWN BUTTON????


Sehka77
 Share

Question

Hi, I have 90 Mack rd690s with e6-300  , I have this button dash .. ***Red shutdown *** would always turn on @ start up then shut down but now STAY  ON CONSTANT WONT TURN OFF **unless I shut off ignition or truck of.

Can someone tell what that is or does? How to fix it thanks 

1614022016885.jpeg

1614022033858.jpeg

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Im guessing its the same as any other R model, oil pressure, water level are two things that spring to mind

In the top tank on the radiator there is a sensor so if you ru  out of water it lets you know, and the oil pressure is self explanatory 

So when the truck isnt running and full of water, you turn the key on, the light and buzzer (bell) come on, you start the truck and as soon as you get oil pressure the light and bell goes off

 

Paul

  • Like 1
Link to comment
Share on other sites

  • 0

So it's not running, in that pic?  cause alt. gauge is showing 13ish volts, (12.6) is normal, with engine off, and the oil pressure gauge is on zero.... temp is up, but low...  or do you have a batt. charger on it with the key on and thats why volts are up? Jojo......

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...