Jump to content

02 Freedom Not Starting .


Mobile-Mechanic
 Share

Recommended Posts

I'm a Mobile Mechanics helper , And A guy came up to me yesterday to look at his 02 Freedom Cab over Renault Powered Box truck , Story I was told Goes like this ! ,. Diesel was stolen from tank , They tried to start it after fueling up , drained the batterys , Replaced the Batterys , Now It will not start .. I tried the normal Troubleshooting methods , Checked fuses , Relays , Check all grounds and Battery terminals and cleaned , I used a push button switch on the starter and Got it to fire over , I Get Nothing from the ignition switch ?? , I checked the wires coming from switch for power with the switch on , and in the crank Posistion , Very Stumped over this issue , Normally I can figure it out and have it back going , But , something I did notice after cleaning the Terminals was the Anti-Theft light on the dash would go off after replacing the terminals ,, Is there an Interia switch somewhere for the anti theft , or Is it something that will have to be done by a Mack Service Dept ?, I'm just trying to figure out the issue and get paid for what I have done so far , but I'm not the type to give up on something and not get paid for working on it all day ,, I also checked to see If I was getting fuel at the injectors and I am getting good pressure ,, But I hear nothing turning on or even clicking from using the ignition switch .. If someone has some Info ,,, PLEASE feel free to throw it my way regarding this issue , I will be going back tomorrow to try and get it fixed , but would like some help tonight if possible ! , Thanks All M-M ! .

Link to comment
Share on other sites

Well ,, Didn't Go back and try anything , rain came in and put us off .. Still would like others insight to this if they possibly know something , I Normally just do Routine Maintenance and smaller repairs . So this Is not really new to me , but Still never worked on a Renault before ..

Link to comment
Share on other sites

here in the Netherlands we have a swith on the gearbox to see if it`s in neutral. sometimes that switch is not working good.then the engine wil not turn over.you have to take of the wiring and put a paperclip in it and it starts.if that`s the problem you replace the switch or put a litle wire in it and leave it that way.but the you can starts it when it is in gear.

Leon.

Link to comment
Share on other sites

I tried to move the lever while in any gear , the drive shaft is removed , the owners removed it to move the truck , but since it could not be started the air brakes were locked , so they used a Fork lift and lifted the rear end to move the truck around , I will try the paper clip and see if that does anything , but not sure If I will be doing it tomorrow or when , I was thinking it had something to do with the anti theft light flashing on the dash , But I will be calling a dealer / Service dept tomorrow to see if they can give me some insight to this matter , But thank you Leon , I will for sure try that when I get to the truck ! .

Edited by Mobile-Mechanic
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...