Jump to content
Sign in to follow this  
Truck#1

Jake Brake

Recommended Posts

Does anyone know how to diagnose jake brake porblems?? Mine works occasionally. The guy i bought the truck from was under the impression that the spring switch near the clutch was the problem. I unhooked the 2 wires and used a jumper but that didn't help. I really dont want to go to the Mack dealer. Any ideas??? Thanks

Rob

Share this post


Link to post
Share on other sites
Does anyone know how to diagnose jake brake porblems?? Mine works occasionally. The guy i bought the truck from was under the impression that the spring switch near the clutch was the problem. I unhooked the 2 wires and used a jumper but that didn't help. I really dont want to go to the Mack dealer. Any ideas??? Thanks

Rob

we may be able to help but need to know some info like what engine and what year and does the jakes work good when they do come on and by that

i mean is it a electric or mechanicecal problem if it never holds goog then it may be under the covers and then you can gather more info from that glenn

Share this post


Link to post
Share on other sites

take a look at the swith on the fuel pump also! it's the one that shut it when give fuel back

Share this post


Link to post
Share on other sites

It's a 98 CH w/427....583, 000 miles ( new cam). I've only bob-tailed with it so I don't know how effective it is under load. When it did come on it seemed to be slow to activate (very gradual) The only thing I have to compare it to is this.....I'm a fireman by trade and drive a ladder truck ( a 2004) with a 515 hp Detroit w/ jakes and an automatic trans. When that thing activates it's like dropping an anchor. I don't know if i should expect the same from an older rig with a manual gear box. Thats really all the info I have.

Once again thanks for your help.

Rob W.

Share this post


Link to post
Share on other sites

One thing I forgot to mention and I don't know if it matters...i have a slight oil leak on right side of engine by the # 1 and 2 cylinders. It looks like it's coming from right above the exhaust manifold.

Rob W.

Share this post


Link to post
Share on other sites
One thing I forgot to mention and I don't know if it matters...i have a slight oil leak on right side of engine by the # 1 and 2 cylinders. It looks like it's coming from right above the exhaust manifold.

Rob W.

Slow to operate can be lots of things these jakes were plegued with oil preasure problems!There were update kits avalible new spings spool s check valves ect. another possibility being the plugs in the end of the rocker shafts can pop out!Does the engine have external lines runing to the jake spacers on the left hand side???

Share this post


Link to post
Share on other sites
Slow to operate can be lots of things these jakes were plegued with oil preasure problems!There were update kits avalible new spings spool s check valves ect. another possibility being the plugs in the end of the rocker shafts can pop out!Does the engine have external lines runing to the jake spacers on the left hand side???

Do check it out the line kit was just one of many fixes for poor response some were as deep as a diffrent oil pump and P 2 main bearings . Best to stick with external fixes this late in the game!You may have to pull the lids and have somone with a little experiance have a look see!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...