Jump to content

Moparmike

Big Dog
  • Content Count

    194
  • Joined

  • Last visited

Everything posted by Moparmike

  1. 2001 rd 688s tech and speed works great but nothing else works no mph trip or hour meter is there away to check repair this ..really need mileage if possible..thanks for the help
  2. I hope so I changed the 3rd relay it had a black burn spot on it..put electric grease on all them .ran 11hrs yesterday no problem so far working it today so far its good.. Thanks for all you guys help
  3. The 4 relays are the only thing I've found in here with big hot wires that run back out the truck
  4. Took passengers side dash off looked everywhere cant find this relay mack said chrome like a ford cant find it ..1 on driver side firewall but they said that's not it..anybody have a picture just for reference that may help me thanks
  5. The 4 power relays are they the relays in need to be looking at
  6. Yes blower motor stops when it shuts down..where can I find this relay at 2001 rd 688s E7 Thank you guys for your response
  7. Install a new sensor on front of engine and in ball housing..would that stop the heater and cruiser from working if so I'll replace them again could have got a bad set
  8. Also cruise control is not working now was working..I cant idle the truck up once air pressure builds but could before
  9. 2001 rd just did inframe less then 1000 miles on it..someone replaced the original engine with a 99 e7 427 same engine from factory just different year put new vecm had mack reprogram it to specs truck runs fine then will shut down red x comes on heater blower everything shuts down wait a few minutes starts right back up run 15 min or less shut down no codes what so ever..please help I'm so deep in this truck and not able to run it ..first did it last week ran bout 12hrs no problem then started this Thanks in advance
  10. Anybody know if I can delete codes are the codes are from my truck
  11. Ok guys put the vecm my buddy has in truck runs great .does the vecm store codes from the previous truck..soon as I started the truck it has 3 codes 1/3 5/5 7/ 2 ..the lighting volt seems to stay on ..can I have the codes cleared and hopefully the light goes out ..drove it about 80 miles home no problem..thank In advance
  12. Friend has a vecu but the last number is a 3 instead of 5 will that make a big difference..its a 1999 EU 427 vecu out a ch I think he said
  13. Yes 2001 rd the computer I need is on the passenger side dash bolted to a cover
  14. Mackpro I've found a company that has a ecm same numbers same engine would I still need a reflash or it would be hit or miss..also what's the average cost of a reflash on the ecm.. Also hi tech in Texas said they would repair what's wrong on my ecm and send it back its 750.00 Thanks for all the help. I've had this truck 6 mths been in the shop all 6 except for 1 week new inframe and clutch now 30 miles down the road ecm goes out ..
  15. 2001 ed e7 what numbers are needed off the computer I have to get
  16. Ok guys update on what I've found.. Took cover off passenger side with computer on it shock white plug light went off truck runs fine..o took computer out cleaned it up put electrical grease on pins reinstalled plugs truck has been running great..thank you all for your help..
  17. Can someone tell me where all the truck grounds are on a 2000 rd I'd like to check those as well
  18. Turn in a driveway this morning and hit a bump truck just lost all power only idle to 900 code 6 4 had that happen before took batteries lose no more problems..today nothing still no power I took the gray triangle shape plug apart with the green yellow and black wire pull ecm fuse let truck sit no battery hooked up even took the plugs off the computer on the passenger side of motor nothing..just went out on job ..first day and 1 hr on new job..Smh ..anybody got any ideas to try right here at Christmas is not a good time to be out of work..or even get run off the job..any help is appreciated thank you
  19. I see there are a few oil plugs on the rear end are they all connected as in does the top 1 feed the bottom are do I need to check and fill each ..didn't want to pull the bottom and fluid goes everywhere..
  20. Anybody know a good source for a pump ..mack here is 770.00 ..but not in stock ..
  21. Ok guys I'm really at a lost here ..I've changed out the 2 on the firewall 1 in the cab still no power..anybody know the location of the fuse inside the cab..or relay that controls them..I still have no brake lights..no power on firewall when pressed or even when I start the truck for the first time to let air build..thanks
  22. Ok thanks ..I replaced the 2 on the firewall does the 1 inside look like the 2 I replaced..airline and 2 wires going to it..
  23. Ok guys truck had brake lights this morning now tonight none..no power to light switch on firewall..is there a relay in the cab or fuse..got dark on me so I didn't get to check alot of things like I wanna get to..all other lights work just no brake lights..thanks in advance
  24. What's a good place to get 1 from and what all needs to be replaced..mines has a hair line crack running in it above the grease cap ..can it be welded or just replaced..
×
×
  • Create New...