Jump to content
  • 0

2016 Mack Granite GU713 w/ MP8.........SCR FAULT DERATE...........NO FREAKING CODES

Monkey with a wrench


So I had a EGR differential pressure sensor high range code.  Replaced sensor a week ago........code came back on.  One of the tubes was clogged w/ carbon.  Took housing off yesterday, cleaned tubes and housing, put back on.  Cleared codes w/ Tech Tool, ran the truck.........no problems.  Left for the night, came back in the morning.........turns out I left the key on........batteries dead.  Put the charger on it, started the truck after charging it.  SCR fault DERATE came on in display.  No CEL light on dash.  Plugged Tech Tool in.......no DTC's.  Ran DPF regens, NOX reductions........any test I could think of for the after treatment system.  Nothing worked.  All sensors seemed to be in range and reading.  Soot level now at 0%.........started at 95%.  I disconnected ALL negative terminals from batteries.  Left them off for 10 minutes, cycled key a few times disconnected, put them back on, code still there.  Last resort........reprogrammed engine ECM with latest download pack from Mack...........nothing.  SCR Derate in 5 minutes!!!

No clue what to do next.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

So yesterday (Monday) I took the truck out and drove it.  Had warning 5 minutes until derate and speed limited to 5 MPH.  Truck went into derate with warning that truck would be limited to 5 MPH at next stop (that would be engine shut down and restart).  Brought truck back to the shop and ran SCR regen (crystal sublimation reduction) and Exhaust Aftertreatment System, Service Regen.  Total Regens between Sunday and Monday was 6.  Soot level came down from 95% to 0% on Sunday.  Soot level was 0% on monday.

Those last regens got the truck out from derate.

I did all this with Tech Tool.  I have no idea what was going on or why it came out of derate on Monday.  I had no codes to work from on Sunday or Monday.  I'm wondering if driving the truck had anything to do with it.

So, ultimately; problem solved.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...