Jump to content
  • 0

1996 E7 350 overflow valve? P7100 pump


TrashMan08
 Share

Question

Whats up y'all. Any ideas would be much appreciated.  1996 all mech 350hp Bosch P7100 pump. Rough idle when cold gets better on warmer days. #1 and#2 cylinder seem to be missing. When i crack fuel lines on these cylinders very little change in running. Seems like low fuel pressure. Did filter change ran fuel cleaner didn't help.  Low on power and low egts (loaded maybe 700). Have cummins 8.3 with P7100 pump as well and has overflow valve on pump return line. These valves go bad on p pumps and sometimes cause this problem, but this truck doesn't seem to have one. Do these pumps on macks have them? Thanks in advance for any thoughts.

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

If it has a miss on thous cylinders you may have an issue with delivery valve washers! on certain models of the pump there are copper washers below the delivery valve nut that can crack and leak by! I would take it to a fuel shop if you have one near by and have it checked It can be done on the truck but you have to have the proper socket to remove the delivery valve nut! 

just my opinion!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...