Jump to content
  • 0

1996 CH613 Electronic malfuction light


juststeve
 Share

Question

  1. My electronic malfunction light came on last week, I replace the speed sensor and the fuel sensor on the injection pump, and checked the reservoir sensor it was good also, unplugged the battery and let it sit over night, started it back up on Monday. light was out and stayed out, Tues fine, Wednesday, the light came back on but would go off when I would move, today it came back on and stayed. Have no power again. I have no speedometer or my fuel gauge now but, have oil pressure gauge and tach works. Thanks
Edited by juststeve
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

My electronic malfunction light comes on when antifreeze reservoir gets low. I'm assuming your problem is bigger than that. When you say you have no power do you mean engine power or power to dash and gauges?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...