Jump to content

Need Help With Smoke Issue


jeffl1107
 Share

Recommended Posts

Hey All,

Posted on other area's with some issues that I was able to fix on my own with help from the guys here. Hoping you could help with one more issue. Finally got tags for truck and is on the road now. 97 mack rd688s tri axle dump with e7 350. I was driving it over to a guy to have some spots welded on the body and my wife was following me. She said that it seemed like most every time I shifted gears but always on intially taking off from start, that it was puffing some dark smoke. I really could not see much as stack is on passenger side above mirror. before i bought it, i saw it come in to yard a couple times while someone else was driving it and i did not notice much smoke at all, but she is saying that it was definately puffing out smoke. It was dark smoke she said which has me a little concerned. The truck only says 379,000 but and the engine looks in good condition. I know this could be a fuel issue or possibly injectors. What do you guys think could be the culprit here. I definately dont want to hear the big "O" word, not yet atleast until I get this thing making some money. Any help is appreciated.

Link to comment
Share on other sites

Hey All,

Posted on other area's with some issues that I was able to fix on my own with help from the guys here. Hoping you could help with one more issue. Finally got tags for truck and is on the road now. 97 mack rd688s tri axle dump with e7 350. I was driving it over to a guy to have some spots welded on the body and my wife was following me. She said that it seemed like most every time I shifted gears but always on intially taking off from start, that it was puffing some dark smoke. I really could not see much as stack is on passenger side above mirror. before i bought it, i saw it come in to yard a couple times while someone else was driving it and i did not notice much smoke at all, but she is saying that it was definately puffing out smoke. It was dark smoke she said which has me a little concerned. The truck only says 379,000 but and the engine looks in good condition. I know this could be a fuel issue or possibly injectors. What do you guys think could be the culprit here. I definately dont want to hear the big "O" word, not yet atleast until I get this thing making some money. Any help is appreciated.

Have you changed oil and filters yet? It could be an air cleaner. That's probably one of the easiest and cheapest things to check. Also, did it start after reconnecting the Jake?

"Mebbe I'm too ugly and stupid to give up!"

Link to comment
Share on other sites

Have you changed oil and filters yet? It could be an air cleaner. That's probably one of the easiest and cheapest things to check. Also, did it start after reconnecting the Jake?

Agree check the air filter!Its likly an air issue possibly boost leak ,highly unlikly an injector issue

Link to comment
Share on other sites

I check the air cleaner. I also agree you guys about the Mack and smoke issues as I have driven them in the past. But this was definitely more than would be expected.

I just found an exhaust leak where the turbo hooks to exhaust so I will have to fix that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...