Jump to content

Haulin trash 759


 Share

Recommended Posts

I have a 04 ch613 with the 460 in it.  I’ve had a lot of trouble with it for one the oil thickens to a clumpy consistency within a 1000 miles of an oil change.  It’s not water in the oil it’s solid black,  no oil in the coolant either.  I’m at a loss on it.  Secondly It’s a roll off truck that I really don’t want to junk the truck if I wanted to replace the motor what options do I have?  Thanks 

Link to comment
Share on other sites

2004 was the first year of the ASET series of engines. They ALL had issues. I've seen this issue before. First off the software and data files should be updated to the latest and greatest. Make sure the engine is not running cold. These engines sit around 200degf. The next thing I would check is the air compressor. If you have coolant in the tanks then you may have coolant leaking into the crankcase. 

If you are to replace this engine with an older emissions type, say a 2003 Etech, you would need to match the vecu as well, have someone who can program it with a vin from a 2003, the chassis harness would need to be reworked but this would work but it's illegal in Canada and some states if you catch my drift......

V

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...