Jump to content
  • 0
Mudman74

05 granite e-7 aset iegr 2-3 blink code

Question

I have a 05 e-7 iegr engine with a 2-3 blink code. FMI 5. I need some help. I have replaced the IAT sensor. The wiring harness is new about 10 months ago. I followed the diagnostic tree for the code and it went away for a couple of days. Now it intermittently comes back on and goes back off. When the lightning bolt comes on the engine fan stays engaged. The plugs look good at the sensor and the ecm. So do the pins. What am I missing?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Is it the IMT sensor or “IAT” sensor?

If you know your harness from point A to point B is in perfect condition be suspicious of ground contacts, even the grounds supporting the newly installed harness. 

Edited by Mack Technician

Share this post


Link to post
Share on other sites
  • 0

Correct me if I am wrong. Isn't the "imt" sensor is on the cegr engine. Either way aren't they located in the same place on the intake manifold under intake ducting?

Share this post


Link to post
Share on other sites
  • 0

Sounds like we’re talking about the same sensor. Would make sense if the fan engages full as a default feature in the engine software. Safeguards to give the charge air column in CMCAC full cooling air flow if EECU manifold temp value signal is lost. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...