Jump to content
  • 0

Changed Odometer still no mileage


Thonyb373
 Share

Question

Hey everybody I’m stuck with this 06 CxN613 I spiked with Mack and they said oh it’s your cluster so after speaking with them and several other mechanics about this no mileage issue they all said the same thing it’s your cluster. I began with not having any mileage or dash lights and everyone said it’s my cluster so I changed it an abracadabra the same problem. So if it’s not the cluster could it be the speed sensor even though I have speed just no mileage. If anyone has had this issue before I would love to get  your opinion. 

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

The mileage is calculated and stored in the VECU ( vechicle  ecm) . The engine hours are calculated and stored in the EECU ( engine ecm) .  Both ECM’s send the data to the dash cluster. Has the VECU been replaced or reprogrammed latley? Does the the speedometer work correctly and is the transmission a Allison or a  Fuller ultra shift?   On a manual trans the speedometer sensor transmits directly to the VECU.  On a Allison the speedometer sensor goes through the Allison ecm I believe. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...