Jump to content

06 Chn613 Loss Of Power


Audioguy2k
 Share

Recommended Posts

Hey, Im new to mack and this forum so bare with me. I recently picked up a 2006 chn613 with a e-7 427 in it. Truck currently has 290,000 miles on it. I have filed bankrupcy since buying this truck due to the crazy amount of down time and shop fee`s on chasing a problem that has never been fixed OR FOUND. Im not that truck savy on diagnostics or anything..Im a parts changer at best but I know when there is a problem. The truck has lost power problem for the past 2 years. Ok,so the boost comes up incredibly slow,(sometimes only build boost once I hit 5th gear) the boost squeals rather than has the normal high pitch clean wistle. The boost sound fluctuates up and down along with the boost gauge (back and forth from 32lbs-25lbs) rapidly. Sometime the boost will spike and hold 40lbs but makes no real power. I dont know what to do and I have alot of trouble trying to explain the problem. Has a new egr,new intercooler,new cooler plumbing,some new boost sensor (? on the driver side firewall?)injector pumps, I get alot of codes popping on the truck but none of them pan out most often is 3-4(forgot what that was) but was told by the mech that there is NO ISSUES AT ALL with the truck. Does anyone have any idea of what this could be or what I could do to check for any intake leaks or if the turbo is bad? Ill spend the money to fix it one last time, and after that if I get nothing out of it Ill have to close shop and go back to being a company man if im lucky. Please help!!!! Thanks so much for your time!!!!

Link to comment
Share on other sites

Hey, Im new to mack and this forum so bare with me. I recently picked up a 2006 chn613 with a e-7 427 in it. Truck currently has 290,000 miles on it. I have filed bankrupcy since buying this truck due to the crazy amount of down time and shop fee`s on chasing a problem that has never been fixed OR FOUND. Im not that truck savy on diagnostics or anything..Im a parts changer at best but I know when there is a problem. The truck has lost power problem for the past 2 years. Ok,so the boost comes up incredibly slow,(sometimes only build boost once I hit 5th gear) the boost squeals rather than has the normal high pitch clean wistle. The boost sound fluctuates up and down along with the boost gauge (back and forth from 32lbs-25lbs) rapidly. Sometime the boost will spike and hold 40lbs but makes no real power. I dont know what to do and I have alot of trouble trying to explain the problem. Has a new egr,new intercooler,new cooler plumbing,some new boost sensor (? on the driver side firewall?)injector pumps, I get alot of codes popping on the truck but none of them pan out most often is 3-4(forgot what that was) but was told by the mech that there is NO ISSUES AT ALL with the truck. Does anyone have any idea of what this could be or what I could do to check for any intake leaks or if the turbo is bad? Ill spend the money to fix it one last time, and after that if I get nothing out of it Ill have to close shop and go back to being a company man if im lucky. Please help!!!! Thanks so much for your time!!!!

In a CHN613 you should have an ASET AC (a variant of the E-Tech E7). Here are some places to check. Start by checking the exhaust manifold and turbo mounting very carefully. They are prone to breaking/loosening fasteners which causes the gaskets to burn out and will reduce boost pressure. Check all of the hoses on the pipes leading to and from the charge air cooler visually, as well as the gaskets on the intake manifold. They will be next to impossible to see, but you might find one that is blown out. You should pressurize the entire system and check for leaks with the turbo outlet plugged off. There is a small boost pressure relief valve on the venturi housing that connects to the exhaust pipe with a steel pipe. It could be damaged or not seating properly. There is an o-ring sealing the venturi to the intake manifold that could be damaged. I've never seen this happen but it probably has. Check the pipe from the EGR valve to the cooler in the area of the bellows as these sometimes break. I haven't seen it happen on one recently though.

"Mebbe I'm too ugly and stupid to give up!"

Link to comment
Share on other sites

Hey, Im new to mack and this forum so bare with me. I recently picked up a 2006 chn613 with a e-7 427 in it. Truck currently has 290,000 miles on it. I have filed bankrupcy since buying this truck due to the crazy amount of down time and shop fee`s on chasing a problem that has never been fixed OR FOUND. Im not that truck savy on diagnostics or anything..Im a parts changer at best but I know when there is a problem. The truck has lost power problem for the past 2 years. Ok,so the boost comes up incredibly slow,(sometimes only build boost once I hit 5th gear) the boost squeals rather than has the normal high pitch clean wistle. The boost sound fluctuates up and down along with the boost gauge (back and forth from 32lbs-25lbs) rapidly. Sometime the boost will spike and hold 40lbs but makes no real power. I dont know what to do and I have alot of trouble trying to explain the problem. Has a new egr,new intercooler,new cooler plumbing,some new boost sensor (? on the driver side firewall?)injector pumps, I get alot of codes popping on the truck but none of them pan out most often is 3-4(forgot what that was) but was told by the mech that there is NO ISSUES AT ALL with the truck. Does anyone have any idea of what this could be or what I could do to check for any intake leaks or if the turbo is bad? Ill spend the money to fix it one last time, and after that if I get nothing out of it Ill have to close shop and go back to being a company man if im lucky. Please help!!!! Thanks so much for your time!!!!

Sorry man theres just too many things to look at to just say its this!It sounds like a sticking egr valve or turbo actuator from here but! As I said its somwhat hard to call with out seeing the unit! Maybe somone else could stick their neck out here but I,m not going to encourage you to spend any more money chasing rainbows!

Somthing that does come to mind thou is if you are not the origanal owner of this truck remove the boost bypass hose and valve and check to see that noone has put a plug in that line that is floating back and forthI seen that happen and it will pound the needle off the end of the gauge.

Link to comment
Share on other sites

Sorry man theres just too many things to look at to just say its this!It sounds like a sticking egr valve or turbo actuator from here but! As I said its somwhat hard to call with out seeing the unit! Maybe somone else could stick their neck out here but I,m not going to encourage you to spend any more money chasing rainbows!

I understand you cant know what it is just from what someone says..Im just looking for some advice on where to start myself,so I dont have to pay the 120$ an hr shop fee. Im going to check the intake again tomorrow...If I spray starter fluid on the intake and surounding area and there is a leak, will the idle race? Also, I checked the impellors and shaft for play on the turbo (and its fine) but someone had mentioned to me that the vanes might not be opening as they should from time to time...This problem I have is VERY intermitten. Does it sometimes and runs great sometimes...When I start the truck first thing and get going it runs like a champ...its when it heats up the turbo starts to scream like a wild boar and looses alot of its pull. Thats what made me think I had an intake leak somewhere (heat=expansion causing leak was my guess)

Link to comment
Share on other sites

I understand you cant know what it is just from what someone says..Im just looking for some advice on where to start myself,so I dont have to pay the 120$ an hr shop fee. Im going to check the intake again tomorrow...If I spray starter fluid on the intake and surounding area and there is a leak, will the idle race? Also, I checked the impellors and shaft for play on the turbo (and its fine) but someone had mentioned to me that the vanes might not be opening as they should from time to time...This problem I have is VERY intermitten. Does it sometimes and runs great sometimes...When I start the truck first thing and get going it runs like a champ...its when it heats up the turbo starts to scream like a wild boar and looses alot of its pull. Thats what made me think I had an intake leak somewhere (heat=expansion causing leak was my guess)

broken studs exhast gaskets plegued these engines all tended to make em squeal! but the boost didnt dart around as you discribe! as was stated preasure check will tell the tale but ya got to have the equipment to do so!Weve made a tool to test the whole system for leaks

A cap to plug the exhast and intake of the tubo, you can put 40 psi on it and everything that leaks WILL show up!

Link to comment
Share on other sites

broken studs exhast gaskets plegued these engines all tended to make em squeal! but the boost didnt dart around as you discribe! as was stated preasure check will tell the tale but ya got to have the equipment to do so!Weve made a tool to test the whole system for leaks

A cap to plug the exhast and intake of the tubo, you can put 40 psi on it and everything that leaks WILL show up!

Ok, Im going to have the system pressure tested. Makes all the sence in the world to me...to bad the mechanics in the new yorks city area feel the oposite. If the pc says the truck is fine, theres no need to look for a problem any more in there eyes...Thanks for the super fast replys and ill let you know what happens with it.... On a side note, anyone interested in buying a 06 CHN613 with low mileage??? lol =o)

Link to comment
Share on other sites

Hey,1 Other thing...1st-5th gear the boost Barely reaches 10lbs loaded or unloaded no diff..I really only start to build boost around 6th gear on.Is this common? I would have to think its not,but this truck has me second guessing EVERYTHING!

Link to comment
Share on other sites

Hey,1 Other thing...1st-5th gear the boost Barely reaches 10lbs loaded or unloaded no diff..I really only start to build boost around 6th gear on.Is this common? I would have to think its not,but this truck has me second guessing EVERYTHING!

We cant tell what others know about things, so there are good , soso and bad tecks, Guys that learn from books and (Thats all ) Theres seat of the pants guys Like me that don't hang on every word spoken in the manual till I see it for myself and guys that can kind walk down the middle of those two lines and dabble from both pots.I don't know if the guys you go too have the where with all to boost / exhast check. We saw a need and we invented a way!Some People hang on everything thing the puter tells em, I Don't I try and apply everything I have learned over the past on a problem!Unfortunatly These skills have been hampered by todays tecknowizardry you now need the puter as they have taken away all the sences we used to use, we now relay on computers and guess work.guy on the other end of the phone saying well maybe try this!:pat:

Anyway if you can ask em to open up all the parramiters in the/ rpm, road ,speed ,road, speed limit, Engine Droop remove any derates that that could cause un explained issues in power and see how it goes!

68 pro or rhasler seem to have a good handle on the puter end of things they may be able to shead a little more light on this ,as to tell em where to go and what to change in the program.

Link to comment
Share on other sites

I agree with you 100% on the tech wizard statement. No one is a mechanic any more, there all comp techs.. I also just thought of another issue that most deff has to do with my problem. I smell and also see coolant (very slightly) around the head area,and when I shut down the truck, there is a noise that sounds like a quick burst of air from a balloon you pulled to tightly..(if that makes any sence to you)....I apreciate all the suggestions of EVERYONE who responded to this post,and please keep the ideas comming as I will be trying all of them. And if anyone knows of a competant mechanic in the NYC area,please give me there info!! Thank you

Link to comment
Share on other sites

I agree with you 100% on the tech wizard statement. No one is a mechanic any more, there all comp techs.. I also just thought of another issue that most deff has to do with my problem. I smell and also see coolant (very slightly) around the head area,and when I shut down the truck, there is a noise that sounds like a quick burst of air from a balloon you pulled to tightly..(if that makes any sence to you)....I apreciate all the suggestions of EVERYONE who responded to this post,and please keep the ideas comming as I will be trying all of them. And if anyone knows of a competant mechanic in the NYC area,please give me there info!! Thank you

The coolant might be coming from the thermostat housing to water manifold joint, possibly from hoses, so check your hose clamps. These engine run 16 psi coolant pressure and it sometimes causes leaks at hose connections that would normally seal at 10 psi. As for your noise check the small steel braided line going from the left side of the engine to the turbo actuator. This is the line that supplies air to make the actuator move in and out. If it has a hole in it it will leak air that should be going to the actuator and possibly be causing your noise. Check the line for kinks too. There is a small filter next to the oil filters, this is the air filter for the air going to the VGT Control valve which sends air to the turbo actuator.

"Mebbe I'm too ugly and stupid to give up!"

Link to comment
Share on other sites

I agree with you 100% on the tech wizard statement. No one is a mechanic any more, there all comp techs.. I also just thought of another issue that most deff has to do with my problem. I smell and also see coolant (very slightly) around the head area,and when I shut down the truck, there is a noise that sounds like a quick burst of air from a balloon you pulled to tightly..(if that makes any sence to you)....I apreciate all the suggestions of EVERYONE who responded to this post,and please keep the ideas comming as I will be trying all of them. And if anyone knows of a competant mechanic in the NYC area,please give me there info!! Thank you

are you sure its not the spinner your hearing after shutdown???????

Link to comment
Share on other sites

are you sure its not the spinner your hearing after shutdown???????

Good call bigen. I take for granted the noise the Centrimax makes when it's spinning down. That shouldn't have anything to do with the powerloss, but maybe it's one more thing to cross off of his list of possibilities.

"Mebbe I'm too ugly and stupid to give up!"

Link to comment
Share on other sites

:banana: No,im 100% sure its not the spinner after shut down..Its one quick burst of air like I have never heard a truck make b4.Ive been driving a while,and doing most of my work myself on my c15`s....This 427 had me spun...ANYWAY, I picked up a couple cans of starter fluid the other day and started going over everything all over again hoping that I missed something this first time...And I did. Where the turbo bolts to the exhaust manifold, and just about that at the egr the gaskets are done...I sprayed alittle fluid in there and the truck idealed up instantly. I must have missed it last time. That is where the whineing noise is comming from and where the squeak/burst of air is comming from after I shut her down. The truck is currently at the mechanic getting fixed (I hope) and I should be back up for monday. I will post the results after I get it back. After driving this truck for 2 years with NO boost from 1st-5th gear and spending about 10-11000 on chasing the problem down,It came to a 2$ can of fluid and 5 mins on common sense...Thank everyone for your suggestions!!! Its greatly apreciated.... Anyone know of a good aftermarket/accessory site for my truck? I was to pull off the single factory stack and put on a nice set of pipes but need the single-dual conversion for under the bunk. Thanks again!!! This is BY FAR the most helpfull anyone has been since I picked this truck up. :thumb:
Link to comment
Share on other sites

  • 3 weeks later...
  • 9 years later...
On 6/27/2010 at 5:12 PM, Audioguy2k said:

Hey, Im new to mack and this forum so bare with me. I recently picked up a 2006 chn613 with a e-7 427 in it. Truck currently has 290,000 miles on it. I have filed bankrupcy since buying this truck due to the crazy amount of down time and shop fee`s on chasing a problem that has never been fixed OR FOUND. Im not that truck savy on diagnostics or anything..Im a parts changer at best but I know when there is a problem. The truck has lost power problem for the past 2 years. Ok,so the boost comes up incredibly slow,(sometimes only build boost once I hit 5th gear) the boost squeals rather than has the normal high pitch clean wistle. The boost sound fluctuates up and down along with the boost gauge (back and forth from 32lbs-25lbs) rapidly. Sometime the boost will spike and hold 40lbs but makes no real power. I dont know what to do and I have alot of trouble trying to explain the problem. Has a new egr,new intercooler,new cooler plumbing,some new boost sensor (? on the driver side firewall?)injector pumps, I get alot of codes popping on the truck but none of them pan out most often is 3-4(forgot what that was) but was told by the mech that there is NO ISSUES AT ALL with the truck. Does anyone have any idea of what this could be or what I could do to check for any intake leaks or if the turbo is bad? Ill spend the money to fix it one last time, and after that if I get nothing out of it Ill have to close shop and go back to being a company man if im lucky. Please help!!!! Thanks so much for your time!!!!

I am having this issue, what did you end up doing. I have spend $$$ to the point of broke and can't fix it. It is driving me to the crazy house. The shops keep telling me to change turbos and acctuators. How many times do I do that to make sure they find the real problem. Please help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...