Jump to content

Em7-300 Wont Start At Times


danovak
 Share

Recommended Posts

I work for a shop and we have various model Macks the one that we are having problems wiyh is a RB690S. Every once in awhile it will not start, it cranks fine but will not fire up and then if you leave the truck sit for a couple of hours it will start right up. Has been to Mack dealer for this problem but they could not find anything wrong. Was wondering were i could find any information on the shutdown system on this truck. It is an electrical system not a cable shutoff. Where is the solenoid or sender actually located on the pump and is it difficult to change ? We have none of the current model engine ,vmac instructional booklets and do you know anyplace to get these booklets without spending an arm and leg ? Or is there a website that has all the information like a motor manual ? Thanks for any information provided.

Link to comment
Share on other sites

I work for a shop and we have various model Macks the one that we are having problems wiyh is a RB690S. Every once in awhile it will not start, it cranks fine but will not fire up and then if you leave the truck sit for a couple of hours it will start right up. Has been to Mack dealer for this problem but they could not find anything wrong. Was wondering were i could find any information on the shutdown system on this truck. It is an electrical system not a cable shutoff. Where is the solenoid or sender actually located on the pump and is it difficult to change ? We have none of the current model engine ,vmac instructional booklets and do you know anyplace to get these booklets without spending an arm and leg ? Or is there a website that has all the information like a motor manual ? Thanks for any information provided.

check the tach sensor on the left side of the bellhousing,I have had the plug spread on some rd690s,rd690p 2001 and found that to fix it.

Link to comment
Share on other sites

check the tach sensor on the left side of the bellhousing,I have had the plug spread on some rd690s,rd690p 2001 and found that to fix it.

More stuff to try!

asuming it is vmac 1 or 2 Not eteck and IF it happens any old time ,also asuming you have no fault light on ,In my opinion you need to have the fuel pump plug repined take it to a dealer and have them put new pins on the fuel pump conector.this very often will cure the problem.

next (IF) the problem happens when the engine gets warm Get a bucket of water and pour it over the back part of the fuel pump then try start the the unit if it starts the fuel pump needs to come off and needs internal repairs try these two things first the water trick is the odvious cheaper of the two (IF) your symtom is as discribed.

Note This info is provided from the Mack book of hard knocks and is not writen in any manual on the face of the planet to the best of my knoledge..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...