Jump to content

'99 MACK RD688S, E7 ENGINE W/ VMAC III LOW POWER PROBLEMS


Recommended Posts

Good morning!!  Long time listener, first time caller.........hope somebody here can help me.  I've been reading these forums for years and learned a great deal.

 

Ok.....hoping somebody on here has experienced this before or is familar with how this system works.
I have a customer with the above truck. He was driving it last week, loaded, when the rpm gauge and speedo stopped working and the engine lost power. The RPM gauge came back but was bouncing a bit.  The engine never shutdown.  He continued to drive, dumped the load, and came back to the shop.  This truck has never been a problem before. I plugged my laptop into it using Texa Truck software to diagnose it. It showed a problem with OIL PRESSURE SENSOR. I replaced it with a new one. That code disappeared.
New code showed up showing INTAKE AIR TEMP SENSOR was no good. Back to Mack I went. Replaced that sensor, rescanned, now the speedo sensor showed up as being bad (data invalid).

So this was Friday...I gave up around 8pm. I went home and bought the VMAC III manual online and read it. It said that if the speedo sensor was bad that it could/ would derate the power. It also talked about blink codes if you hit the cruise control resume switch so many times to display the code. I am not sure where the blink code is supposed to show up. This is an old truck. So there are a bunch of things not working and held together with baling wire and duct tape.  Doing a bulb check by cycling the key, I can't find a check engine light.  Shining a flashlight into the bulb bezels I see 'STOP ENGINE', ABS, ETC.  One bezel is missing, the bulb for that is down behind the dash and is lit constantly with key switch on.  It goes out when the dash power times out after turning key off.  Using the Accel/ Resume button doesn't produce a blink code and the cruise control is in the 'OFF' position (as per VMAC III manual).

SATURDAY
So I ohmed out the speedo sensor and it was reading 1.4 M ohm.......no good. A good sensor is supposed to read between 150-170 ohms. Off to Mack again, new speedo sensor, checked on meter and it read 164 ohms. Plugged it in, rescanned, still showing bad speedo sensor. Pulled VECU from passenger side dash panel and ohmed out J2 PLUG J2-11 and J2-12 for the speed sensor. From the pins at the VECU, I got 164 ohms. Checked power to VECU at J3 plug. Using J3-16 (12V from battery) to J3-18 (VECU ground) I got 13V (battery voltage). J3-17 (12V from Accessory Relay) to J3-18 (VECU ground) I measured 0 volts. I tried jumping from J3-16 to J3-17 in case that should have been powered as well.........it didn't change anything. I ordered a new VECU from Mack.

WEDS.
The NEW VECU showed up yesterday and I put it in today. Code for the speedo sensor disappeared. Now it said the Accelerator Position sensor was out of calibration. I am assuming ............I don't have anything confirming this.........that the throttle position sensor calibration was in the old VECU. Tried calibrating it with Texa software. It didn't work. Tried 4 times........no goes all the way. Called Mack...........new throttle sensor is $300 and is 5 days out.

So we are up to $1200 and the truck has been down for a week.
Replace one sensor and another shows up bad. Always 1 sensor at a time, which is frustrating. Right now the Engine ECM is good, no codes. The tach, oil pressure, and speedo all work as they should now. With replacing the VECU, the speedo came back to life. Still have lack of power in the truck.

Other tests of note.........I checked fuel pressure first. It reads 110 psi at idle. On test drives, fuel pressure never dropped below 100 psi. Turbo spins free, no damage, no bearing play. No black exhaust while driving from lack of boost showing unburned fuel.

I'm at a loss here. AND WHY THE HECK DOES THE LAPTOP ONLY SHOW 1 BAD SENSOR OR CODE AT A TIME?? Fix one and the next shows up.........like its daisy chained or something. Runs into 1 bad sensor and then it stops and just displays 1 code. Is that normal from this generation system??
Or maybe its the air pressure in the LR tire is low??

  • Like 1
Link to comment
Share on other sites

So I have this posted over on Heavy Equipment Forums.

One of the members over there just posted that I have overlooked the obvious. 

I NEVER PUT A LOAD TEST ON THE VECU power supply...........or for that matter, the Engine ECM.  I just assumed my trusty multimeter would tell me the truth...........and it did........without a load.  Even more frustrating...........I've played this game before, I have a round headlight in my truck specifically for this purpose.  I never checked the battery connections.......just the relays and fuses.  I'll try and get that done today and post the results.

Its odd that the speedo didn't work before, but now it does.  Oil pressure gauge reads fine, tach working correctly now.

  • Like 1
Link to comment
Share on other sites

You may have a light bulb that may of fell in behind the dash for the check engine light and its burned out. 

In order for the speedo sensor to go inactive, you have to drive the vehicle. So plug in the old VECU and try that first. 

AS for the daisy chain, can't help there.

Let us know what you find.

V

  • Like 1
Link to comment
Share on other sites

After replacing the speedo sensor, and ohming out the sensor from the pins at the J2 plug, I drove the truck with the old VECU plugged in.  No speedo active.  Replacing the old VECU with the new one, speedo became active and worked.

Had error message on Texa showing bad or out of calibration accelerator position sensor.  Tried 6 times to calibrate accelerator position sensor w/ Texa.  Not sure if its working.  Out of frustration, I just ordered a new one.

  • Like 1
Link to comment
Share on other sites

The VECM needs to be programmed.  So the truck characteristics need to be pulled off the old VECM and transferred to the new one. And it needs to be in the truck when its done.......and since the truck only goes 10-15mph at present, guess I'll be low boying it up to the Mack dealer.

So I had a chance to check the throttle position sensor today. Its getting 5.2V open voltage through the sensor harness ground. Plugged it into pedal and was getting 4.85V plugged in. Voltage on variable side was 4.85-1.2V when I pressed on the pedal.....so that's working correctly. Pulled panel for VECM, unplugged J2 and connected incandescant headlight up to it, using harness ground as well. Open voltage was 12.25 w/ no load. Headlight on it was 11.87V.....so no power problem. I then called a Mack dealer in MA, who were super friendly and helpful; and talked to parts........yes, it needs to be programmed.........they then sent me to service to verify.......again, super helpful (not like the Mack dealer in NH we have an account with). They verified it needs to be programmed in the truck (actually that was the first time I heard that). I called our local Mack dealer to try and talk to service......everyone was at lunch and they'd have someone CALL ME RIGHT BACK!! 3 hours later, I called them. They verified it needed to be programmed with the truck characteristics and that I'd need the old VECM. They said they could get to it on Tuesday....maybe........today is Weds. If the other Mack dealer in MA wasn't so far away, I'd be trucking it there.
Thank you for everybodies input. I appreciate. Hopefully this post can help someone else out.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...