Jump to content
  • 0

Jake brake and cruise control switch failure.


Gosstruck
 Share

Question

I have a 2007 Mack granite ctp713 that has and occasional issue with the jake brake and cruise control switches. They quit working at the same time whenever it happens but they will quit working anywhere from a few minutes to days at a time. When they’re on they both function properly. Cruise it’s my issue. I rarely use it but I need my jakes. Any ideas or opinions?

Edited by Gosstruck
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
On 1/22/2019 at 9:12 PM, Mackpro said:

A malfunctioning clutch pedal switch can take out the cruise and engine brake . If the VECU thinks the clutch pedal is depressed, cruise and engine brake won’t work 

But the lights for both switches go out when this happens as well. When you press the clutch the lights on the don’t go out when they are working properly. When you turn cruise on there’s a backlight inside the switch. Same for the jake. Whenever it malfunctions the backlights don’t even come on.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...