Jump to content
Sign in to follow this  
wrenching4life

04 Granite CV713 no ABS light or self check

Recommended Posts

Hey all I have an 04 Granite you turn the key on there is no ABS light bulb check in the dash and also i don't hear the ABS self checking on the chassis the "clicking" noise. Iv checked the fuse on the driver side firewall and iv checked the two circuit breakers inside the cab on the pass side all have power and are in good working order, any thoughts? thanks all!

Share this post


Link to post
Share on other sites

I found a third in the glove box and all are in good shape. still no self check and their is 12v at all the breakers and fuses. any other thoughts?

Share this post


Link to post
Share on other sites

You will need to check for powers and grounds to the abs module. The module in mounted on the right hand kick plate next to the vecu. You will need to remove the plate.

  • Like 1

Share this post


Link to post
Share on other sites

you would not happen to have a wiring pin-out or  diagram would you? or any other further diagnostic? 

Share this post


Link to post
Share on other sites

Hi I figure it out. There is relay under the hood called TRLR ABS POWER some mechanics will remove it to not work on the ABS light. I had the same issue with a truck here in the shop and I just put a new relay in it form Mack. Also there is a fuse under the hood called 49 (10A) ABS IGN make sure the one is good. It’s how I fix the same problem your having.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...