Jump to content

Eaton/Fuller 13 speed problem


rondefly
 Share

Recommended Posts

Please help, In the two top positions when I take foot off throttle it disingauges and if I press on the throttle again it re-ingauges, this will happen in high range, could this be a air pressure problem, or something in the trans. also the two top positions don't feel like it goes fully into them when I shift.

Ron Triano this is a 2001 Vision CX613, 007564

Link to comment
Share on other sites

Top two positions meaning, 8 hi/lo and 9 hi/lo or just 9 hi/lo? What do you mean disengages? Does the shifter slip out of gear and back into neutral?

"Any Society that would give up a little LIBERTY to gain a little SECURITY will Deserve Neither and LOSE BOTH" -Benjamin Franklin

"If your gonna be STUPID, you gotta be TOUGH"

"You cant always get what you want, but if you try sometimes you get what you need"

Link to comment
Share on other sites

sounds like a pressure issue in the back box shift solenoid to me, how do you know its out of gear?

"Any Society that would give up a little LIBERTY to gain a little SECURITY will Deserve Neither and LOSE BOTH" -Benjamin Franklin

"If your gonna be STUPID, you gotta be TOUGH"

"You cant always get what you want, but if you try sometimes you get what you need"

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...