Jump to content

Dash Lights.......... yes I saw the other post for the same thing..


Recommended Posts

Hello, I have 2000 Mack Vision CX613 tonight I went to turn my lights on and guess what .......... BAM no back lighting.... the backlight aroud the odometer is light up.... checked the dimmer...... just fine................ breakers and fuses are good......... pulled dash apart no loose wires...... Could it be the circut board? or is there something else I am overlooking...??????????? Thank you!!

Link to comment
Share on other sites

Check the bulbs? They are little pricks. look for small black lever type things. They turn and the bulb will be there.

Had to replace several bulbs in my 2001 CX

Success is only a stones throw away.................................................................for a Palestinian

Link to comment
Share on other sites

if they are all out it makes me think the dimmer is bad, or a wire from the headlight switch, gotta be a fuse or a switch issue, there aint much else in the circuit.

"Any Society that would give up a little LIBERTY to gain a little SECURITY will Deserve Neither and LOSE BOTH" -Benjamin Franklin

"If your gonna be STUPID, you gotta be TOUGH"

"You cant always get what you want, but if you try sometimes you get what you need"

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...