Jump to content

Hard Starting Ch613


Recommended Posts

My 1993 CH613 starts fine inside. Leave it outside and well you have to put either to it to get it going. When it gets going it will run rough for matbe 10 seconds, then it clears up. It has a new starter, fuel filters and a drainback valve. I'm puzzeled any ideas would be a great help.

Check the fuel return jumper (from head to head)between the valve covers. They have rubber o-ring/seals that start to leak after many years and can let air in and let fuel drain back to tank on some types of injector pumps(depending on the type of overflow valve on the injector pump) I think it takes a 7/16 wrench, just tighten the 2 nuts usually they are really loose.

Link to comment
Share on other sites

Check the fuel return jumper (from head to head)between the valve covers. They have rubber o-ring/seals that start to leak after many years and can let air in and let fuel drain back to tank on some types of injector pumps(depending on the type of overflow valve on the injector pump) I think it takes a 7/16 wrench, just tighten the 2 nuts usually they are really loose.

I will check that out and I will send back what I discovered. THANX

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...