Jump to content

Engine Shut Down (Check Trans)


Recommended Posts

Wondering if anybody else ran into this.I have a 2005 Mack Vision with a 460 13 speed eaton trans,I'm getting every once in a while engine shut down light and "check trans" coming on,when this happens my heat gauge for my trans drops to nothing,then when the light shuts off it goes back up to normal operating temperature.Checked all the wiring going to the heat sensor on the trans back and seems fine,possibley a heat sensor on trans getting bad?Or when the heat sensor on the transmission goes it just goes?Any input would be great ,thanks! p.s. she has high miles on her

Southern Girls Rule!136.jpg

Link to comment
Share on other sites

i got my 2004 vision late sumer every week its some thing like that. i pay for fuel, drive for free, and it wont make enough to pay for its repairs, i didnt know about 2003,04,05. i feel sorry for you if its not paid for, it will put you out of buissnes quick. it is the most comfortable truck i have ever sat in,runs and pulls like its pissed off, but constant huge repair bills are running me in the ground. good luck.

Link to comment
Share on other sites

i got my 2004 vision late sumer every week its some thing like that. i pay for fuel, drive for free, and it wont make enough to pay for its repairs, i didnt know about 2003,04,05. i feel sorry for you if its not paid for, it will put you out of buissnes quick. it is the most comfortable truck i have ever sat in,runs and pulls like its pissed off, but constant huge repair bills are running me in the ground. good luck.

Yes I have heard alot of horror stories.I know a company that has a fleet of them,yes cheaper truck to buy but will put you under when it comes to repairs.I have been very lucky in that department(knock on wood!),just an exspensive trubo($5000)and two EGR coolant valves,a bearing in the rear end,starter(normal),plus not the greatest on fuel,but all in all she's been pretty faithful,she runs pretty hard each week,but usually only tandem weight(45,000lbs would be heavy for her).I see your girl is a heavy hauler.Hopefully Mack WILL go back making REAL trucks again someday.You couldn't beat the old ones!

Southern Girls Rule!136.jpg

Link to comment
Share on other sites

  • 6 years later...
  • 4 weeks later...

Something I see sometimes when this happens is the wires at the connector plug start to fray inside the insulation before they end up breaking or the connector housing on the sensor is cracked. The temp sensor is located on the right side of the trans near the 6 hole pto cover. Sometimes debris from the road will kick up and damage the sensor. On v-mac 3, the shut down feature can be turned off. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...