Jump to content

terantrucking93

Puppy Poster
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

1 Good

About terantrucking93

  • Rank
    First Gear

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I found it it was the starter I had another issue with this truck my abs and lighting and atc are on on my dash trucks runs fine only the dash it take off the back wheel n clean the sensor but on the front I can’t get to it any help? Sent from my iPhone using Tapatalk
  2. I change a starter on my truck it is a chu 613 mp8 2014 Mack I had the issue it only clicks Random and start I had to work the switch by 20 times and it starts I put new starter it comes with the selenoid starter and another part but it is doing the same I just randomly starts I need some help Sent from my iPhone using Tapatalk
  3. What do u use to take the coolant filter? Sent from my iPhone using Tapatalk
  4. But I keep muy speed at 65 on 9th gear when it drops to 13 rpm the truck start to shake Sent from my iPhone using Tapatalk
  5. Today I clean my 7 inyector this morning seen I bought the truck I was making no more than 6 mpg right now it’s showing 6.7 Sent from my iPhone using Tapatalk
  6. What’s the mpg u getting with new injectors Sent from my iPhone using Tapatalk
  7. I had the same issue what I did on mine i poor a stop leak from gas station I poor it stop the leak N I clean Raines all and put new antifrezze and I been running 7 months with any issue on my coolant Sent from my iPhone using Tapatalk
  8. Have u change the coolant filter? Sent from my iPhone using Tapatalk
  9. left side it is froze .my compressor it is doing the cycling Sent from my iPhone using Tapatalk
  10. I have one more question my lines for my a/c they freezing up I blow my condensor it’s clean from the outside I know it has a filter but any body can get me a location Sent from my iPhone using Tapatalk
  11. Found it thank u Sent from my iPhone using Tapatalk
  12. I have the same issue can y’all tell me where it is locator the ahi module I have the same mp8 I can’t find it Sent from my iPhone using Tapatalk
×
×
  • Create New...