Jump to content

CV7132005

Puppy Poster
  • Content Count

    14
  • Joined

  • Last visited

Community Reputation

1 Good

About CV7132005

  • Rank
    First Gear

Location

  • Location
    Webster, Massachusettes

Profile Fields

  • Interests
    Mack trucks

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. thanks for the info. a guy I know that works at my local mack dealer said that its around the time for a rebuild. just not sure if I should do an inframe or get a reman
  2. Its using about a gallon per week plus or minus. mostly my weeks consist of around 1300 miles. I've always changed the oil at 300 hours 5500 miles
  3. hello. I have a mack granite with an AI 427. she has 24k hours on her and she's using oil. I know that's pretty high hours, but just wondering what the acceptable mount of consumption is. thanks
  4. I have a 05 granite with a 427 with 24k hours. Just changed the oil today and noticed some fine metal on the magnetic drain plug. I've owned the truck for about 8 years and never noticed it before. I had rods and mains done last winter. Is this something I should be worried about?
  5. Hello, I've got a 2005 granite with 546k miles. The engine has 24k hours, runs excellent, great power but it started using some oil recently. It seems to be about 3 quarts per week. I average about 1200 miles per week. Just wondering how much is too much. I bought it with 135k on it. I Also replaced the turbo a year or so back. Thanks in advance.
  6. Hi, I have a 2005 granite. When it is cold the fan doesn't like to shut off. It proceeds to come on and off continuesly. I took the high pressure switch out of the equation and jumped it with a jumper wire and it didn't change anything. I have replaced the fan solenoid, water temp sensor, oil temp, and the air temp sensors as well, nothing has helped. Any help would be appreciated. I'm afraid it's going to ruin the clutch seeing how its never directly ingauged.
  7. I have a 2005 granite with an AMI 370. I was wondering if anyone had some info on how to test the ambiant/humidity sensor located in the intake tube right after the air filter. Thanks in advance
  8. I have a 05 granite and I recently purchased a cluch fan override switch, since I found the wiring harness in the dash. However it does work and was wondering if there was a relay needed. I can't seem to find anything in the fuse panel. Thanks
  9. Eventually I will probably put a 5" exhaust from the turbo back and a K&N air filter as well
  10. I haven't worked it enough, things are slow now but I did test drive it and on a hard pull in 7th the pyro was at 1025 water was normal 200. The fan didn't come on either.
  11. I just completed installing 2.5 stage injectors, and the turbo to go with it from Rochester. I have an 05 granite AMI 370. She always did good but this Definitely woke her up. I also replaced the exhaust manifold with an older ETECH manifold. I don't have many hrs on everything yet but very happy so far. Pulls great!!
  12. Thanks. I'm not sure where to find that though
  13. Hello everyone, I'm new to the group. I have a 2005 cv713 with a AI 370. I was wondering what the fuel pressure should be at idle and operating range. I'm having a little bit of a power issue all of a sudden. Thanks.
×
×
  • Create New...