Jump to content

  •  

  • Welcome to BigMackTrucks.com

    Welcome to BigMackTrucks.com, the best resource on the Internet for Antique, Classic and Modern Mack Trucks!  

     

    Please login or register to take advantage of everything BMT has to offer.  Memberships are Free and offer many benefits:

     

    • Start new topics and reply to others
    • Subscribe to topics and forums to get automatic updates
    • Showcase your trucks in our Garage
    • Photo Gallery, Member Blogs and much more...
    • Add events to our community calendar
    • Create your own profile and make new friends
    • Customize your experience!
    • Mack Dealer and Corporate personnel can contact the ADMIN after registration for access to the Dealer Forums.

    If you are having trouble logging in or haven't received your validation email, you can post as a guest in the Guest Forum.


    login  register
    Guest Message by DevFuse
     

    Photo

    Volvo no jake brakes



    • Please log in to reply
    4 replies to this topic

    #1 OFFLINE   s13muskrat

    s13muskrat

      First Gear

    • Puppy Poster
    • PipPipPip
    • 13 posts
    • Location:Anadarko Oklahoma
    • Make:Mack/Volvos
    • Model:18 Trucks
    • Year:2004 and up

    Posted 25 March 2013 - 01:01 PM

    Im working on a 2010 volvo d16. Driver said she was pulling into a truck stop and push in the clutch and she herd a loud pop. now the cluctch is stiff has trouble going into gear, no jake brakes and no cruise control. they are not in the yard yet so i kinda wana have an idea on where to look.



    #2 OFFLINE   refusegetter

    refusegetter

      BMT Veteran VIP

    • Bulldog
    • PipPipPipPipPipPipPipPip
    • 252 posts
    • Location:RI
    • Make:Peterbilt
    • Model:379exhd
    • Year:2006

    Posted 25 March 2013 - 01:07 PM

    Maybe the switch that the pedal pushes to turn off jake and cruise has been "relocated"

    #3 OFFLINE   s13muskrat

    s13muskrat

      First Gear

    • Puppy Poster
    • PipPipPip
    • 13 posts
    • Location:Anadarko Oklahoma
    • Make:Mack/Volvos
    • Model:18 Trucks
    • Year:2004 and up

    Posted 25 March 2013 - 01:14 PM

    Relocated?



    #4 OFFLINE   Challenger

    Challenger

      BMT Veteran VIP

    • Big Dog
    • PipPipPipPipPipPipPipPip
    • 210 posts
    • Location:Pa

    Posted 25 March 2013 - 03:56 PM

    Probably has something to do with the clutch pedal.  Like stated above the cruise and jake switch operates off of the clutch pedal.  The clutch, jake, cruise switch is the gray switch towards the foot pedal.  Check the clutch pedal and clutch operation, the problem is there somewhere.  



    #5 OFFLINE   refusegetter

    refusegetter

      BMT Veteran VIP

    • Bulldog
    • PipPipPipPipPipPipPipPip
    • 252 posts
    • Location:RI
    • Make:Peterbilt
    • Model:379exhd
    • Year:2006

    Posted 27 March 2013 - 05:35 AM

    By relocated I meant the bracket or whatever hold the switch in place has been bent or twisted causing the hard push and the switch being pushed in as well.




    0 user(s) are reading this topic

    0 members, 0 guests, 0 anonymous users