Jump to content

CXU613 mp8 no crank.


Adam9066
 Share

Recommended Posts

I have a 09 cxu613 that will not crank. We checked all the relays and fuses. We put a crank switch on the solenoid and the starter does turn over. I check the ignition switch and had 12 volts on all terminals.  When you turn the key you can hear the relays clicking away. We hooked the truck to jpro and the engine ECU does not show. I took a gamble and replaced the chassis harness and the engine harness was replaced in 2013. 

 

The driver told me he went to start the truck and it starter for 30 second said dpf fault shut down and would not crank.

 

I'm thinking the ecm might be bad. Anything else I can check?  Im guessing a new ecm has to be programmed by the dealer like the dash?

 

I forgot the exact codes but we had a psid 200 and psid 230. One was fmi 4 and the fmi 9 but I forgot which was wich.

Edited by Adam9066
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...