Jump to content

2012 chu613 speedo not working 1400 rpm

Recommended Posts

2012 chu 613 speedometer quit working and derated to 1400 rpm. Replaced speed sensor tried accelerator pedal rest ecu and vecu using tech tool and then disconnecting batteries and still no headway.. The computer says to check groind at vecu using pin test kit. Does anyone know which pins to test or if you can test with out a pin kit. 

Link to comment
Share on other sites

  • 9 months later...
  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...