Jump to content

Cold Weather Relay Problem


Mbmaring
 Share

Recommended Posts

I have a problem with a 99 mack ch 613 with a e7 400hp when you go to start it on a cold day like below zero you turn on the key and try starting it and it will not fire then you shut the key off and the parking brake light and the low air pressure lights stay on and will not shut off untill you disconnect the battrey then sometimes you can get it to start when you hook up the battrey but it will not start if that relay is sticking the only problem is I cannot find the relay that is sticking I tried unpluging one by one the relays under the hood but it is not one of them where are the other relays that could be causing the ignition sticking problem?

Link to comment
Share on other sites

  • 2 weeks later...

It could be the large master solenoid/relay over in front of the passangers seat. Mine acts up once in a while doing similar things. i think its only twenty bucks right from mack. Don't replace it with anything eles. most solenoids are only momentary duty. this is a full duty solenoid

There Is No Replacement, For Displacement!!!!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...