Jump to content
  • 0

2008 mack with mp7 regen issue


INTERCEPTOR
 Share

Question

we have a 2008 mack 600 garbage truck with a mp7 and allison 4000, the truck had a dpf and egr delete a few years ago, (dpf emptied, egr capped and ecm flashed) and one day it got stuck on derate, its coding SPN 3483 FMI 08 (so regen statut) and SID 21 FMI 01 (cam shaft position sensor, dealership keep replacin sensor with no result) and when i look up the dpf on Jpro it say the soot level is at low and regen is not needed, i tried forcing a regen anyway to see what would happen and nothing happened as expected, we had the ecm reflashed a second time by a different shop but it didnt fix the issue, i still think the issue is coming from the dpf delete on the ecm, has anyone experienced something similar in the past?

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...