Jump to content

95 RD688S-No Stop or Turn Signals


Recommended Posts

Currently have no directionals front or rear, and no brake lights. Checked fuses all good, plugged in brand new turn signal switch, no change. Tested in fuse box, no hot to the flasher. Schematic shows fuse feeds the flasher which feeds the circuit,Could my panel be shot? Appreciate any ideas. It's odd to loose both at once.

Link to comment
Share on other sites

Problem solved. Must have missed a fuse when checking. After spending the day yesterday troubleshooting from a schematic that I was told was my trucks, (it became apparent that it was similar, but not the same as mine as I was troubleshooting) I was able to pull the fuse box info from this site for a 96 Mack. Checked my truck today, fuse 16 for turn signals blown, replaced, left turn worked fine, right turn. 3 blinks then pop, blew fuse. Unplugged front end harness from near passengers side firewall, replaced fuse same result, (ok short is not in front harness). Plugged back in, replaced fuse, hooked up new turn signal switch, left turn ok, right turn -good to go. Short must have been in the signal stat all along. Shame on me for missing the blown fuse the first time!

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...