Jump to content

EGR MOD


dpacella
 Share

Recommended Posts

I have a 2005 Mack with Aset AC355/380.

I put a plate in between the exhaust manifold and EGR.

Now I notice that the check engine light (EGR fault 146-7) comes on, I can feel the engine de-rate, but as soon as the check engine light goes off the power is back.

The check engine light comes on maybe once or twice a day.

So I was reading about how to add resistors to the flow sensors to trick the ECM into thinking that the flow sensors

are working properly.

I cut the two flow sensor harnesses that go into the firewall side of the ECM and installed two separate 270 ohms 1/2 watt resistors

After installation of the resistors a check engine light came on and gave a fault code 21-5?

Now I'm guessing because code 21-5 is not it the fault code book. I looked up code 21 its the engine position sensor and code 5 was current low/open???

I am stumped at the moment and was wondering if someone can shed some light on my issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...