Jump to content

Abs Light On


Recommended Posts

Hey guys, I have been checking out this site for a while now, and have got some great info from the mack guys on here. Now I have a question of my own... I have a 99 RD w/ 350 etech and the ABS light is on. When I push my ABS diag button under the dash the light flashes 4 times then a short pause then 4 more times. Called my local Mack dealer they couldnt tell me what that code ment. They figured it was a sensor but I was wondering if someone could tell by the code what it was specifically. I have a list of codes for the electronic malfunction light, but no list for the ABS, where would this be available. I would just like to pinpoint the problem some before Just go guessing at stuff , any info is useful... thank You!... Andy

Link to comment
Share on other sites

Hey guys, I have been checking out this site for a while now, and have got some great info from the mack guys on here. Now I have a question of my own... I have a 99 RD w/ 350 etech and the ABS light is on. When I push my ABS diag button under the dash the light flashes 4 times then a short pause then 4 more times. Called my local Mack dealer they couldnt tell me what that code ment. They figured it was a sensor but I was wondering if someone could tell by the code what it was specifically. I have a list of codes for the electronic malfunction light, but no list for the ABS, where would this be available. I would just like to pinpoint the problem some before Just go guessing at stuff , any info is useful... thank You!... Andy

Assuming you have Meritor Wabco Version D or E ABS a 4-4 blink code is for the driver's side rear axle wheel speed sensor.

"Mebbe I'm too ugly and stupid to give up!"

Link to comment
Share on other sites

I am unsure on what kind it is, but thank you very much that will give me a place to start. I am wondering if maybe I got dirt in there to screw up the sensor, i was dumping gravel in a muddy area and had the duals in the slop pretty good. How do i figure out what type of abs system I have?

Link to comment
Share on other sites

I am unsure on what kind it is, but thank you very much that will give me a place to start. I am wondering if maybe I got dirt in there to screw up the sensor, i was dumping gravel in a muddy area and had the duals in the slop pretty good. How do i figure out what type of abs system I have?

If I remember correctly the ABS module has a label that will say what version it is. For your year model Meritor/Wabco version D was popular (it may have been the standard configuration for ABS). Dirt, rocks, leaking wheel seals and the like can bump the sensor and cause it to lose contact with the tone ring on the hub. Another area to check would be the wiring going to the sensor where it is tied to the air hose going to the brake chamber and where it is tied to the S-cam bracket.

"Mebbe I'm too ugly and stupid to give up!"

Link to comment
Share on other sites

Thank you rhasler, I will check this out tomorrow, havent seen any oil anywhere so that is a good sign, I will pull the wheels and check all this stuff out. First truck with ABS so didnt really know where to start. This will get me in the right direction, I will keep ya posted. Thanks a bunch!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...