Jump to content

Jamesc83

Puppy Poster
  • Posts

    8
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Jamesc83's Achievements

Rookie

Rookie (2/14)

  • One Month Later
  • Dedicated Rare
  • First Post
  • Week One Done
  • Conversation Starter

Recent Badges

0

Reputation

  1. Hi everyone I have a 05 cxn613 with an aset 350 engine and I’m wondering is there updates or a trick to keep these going from going out. thanks
  2. Update: I replaced check valve, and checked for leaks could not find any so far. See where this thing goes thanks for all the feedback!
  3. I have a 03 cx613 with AC 350 and it will have a loss of prime intermittently when shut off for the night or week. It doesn’t do it constantly any ideas or feedback would be appreciated. thanks
  4. Yea if the key is off and I push the buttons it does nothing.
  5. Yea it’s a on road truck it has two buttons on the cluster to push the rubber part of the buttons are in tact. I have xc613 similar to it as well and I can’t get that one to work either so I thought maybe I’m doing something wrong. Iv had the face cluster off but didn’t use any compressed air.
  6. I have a cxn613 and I cannot zero out my trip or toggle threw any functions. Cant do anything! An ideas! thanks
  7. I have a 05 cxn613 with aset engine and having code 4-5 come up when using the jake brake and idling. I’m wondering if anyone knows why that is coming up and what needs to be done to fix that. thanks
×
×
  • Create New...