Jump to content

Ali Carmona

Puppy Poster
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

1 Good

About Ali Carmona

  • Rank
    First Gear

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Yes let me tell you: finally I tuck the truck to another mechanic recommended by my friend, and he figure it out that the turbo cooler was having an air leak and the head gasket needed to be replaced because it was leaking a lot of coolant, also he calibrate the valves and after this repairs the truck is running really good. It is having a lot of boos like it was before. Thanks very much for your help. The gasket from the intake was good so it wasn’t needed to be replaced, about the sensors, I figure out that they were not the reason for the low boost. The truck is running really smooth now. Sent from my iPhone using Tapatalk
  2. Is there anyway that I can erase the codes once I change the sensors? Sent from my iPhone using Tapatalk
  3. Ok I going all this codes 21 - 42 - 25 - 26 - 24 - 31 - 14 I really don’t have any idea of what it means! Sent from my iPhone using Tapatalk
  4. No I haven’t done them yet, I’m just wondering I don’t have to much time in this business and I have many questions yet, and I just want to be prevented because there was a mechanic who told me that maybe I’ll need a rebuild so I don’t know if he wants to get my money or if he is serious. But thanks very much for your advices. Sent from my iPhone using Tapatalk
  5. Would it be worth it to rebuild the engine? Or thinking to buy another truck?
  6. Thanks very much I’ll work on this things and I’ll let you all know if the problem got resolved. Thanks again Sent from my iPhone using Tapatalk
  7. It’s also the abs light on, but this orange light of the lightning it’s been always on since I first started driving this truck about 2 years ago, well when I turn it on only.
  8. Yes it is a e7- 460 Sent from my iPhone using Tapatalk
  9. I really do t know, I bought this truck 1 year ago, I was driver for the company before and it was running great but now is happening this. How do I know if it’s what you’re asking me? Where can I check that? Sent from my iPhone using Tapatalk
  10. hello, I have a Mack CX613 2001 with e7 engine, the truck has problems of boost preasure, sometimes it works normally with 30psi or more, but most of the time the pressure drops between 25-20psi, we already check the turbo and it is in perfect condition, change the joints of the turbo pipes, change the metal hose that goes from the air compressor and passes behind the engine, every time we do something it improves a little, but after 2 days of being operating, the psi again go down to 20-25psi, plus it is remarkable the lack of power when this happens, plus I noticed that sometimes the engine shuts down when I go on the road and I have to stop, remove the ignition key and when I try to turn it on, it lights without any problem, but the symptoms of low boost are not solved, also is good to mention that the pressure of the oil is also in between 40-50psi when operating temperature, the engine is getting worst really slowly but gradually if someone knows the reason of these problems and why they are generated, I would be grateful to guide me in what I can do to solve the problem. Thank you. Sent from my iPhone using Tapatalk
×
×
  • Create New...