Jump to content

kkheitman

Puppy Poster
  • Content Count

    15
  • Joined

  • Last visited

Everything posted by kkheitman

  1. Thanks for getting that part number dor me. That explains why the parts guy missed it.
  2. I can wait if you can get the part number, that would be great
  3. Was at the mack dealer today and they don't show a washer in there
  4. I think you might have nailed the problem
  5. No there is no washer between the bracket and the housing.
  6. Thanks Mack Technician a wealth of information there. I'm headed to a different mechanic this morning with the info you've provided. Spoke with him last night and he's pretty much on the same page you're on, he also couldn't believe they welded it to the cover. I'll let ya know what the outcome is.
  7. What makes you think it would be cracked?
  8. I tried that and get no movement at all
  9. Bronze bushings less than a year old
  10. Joe, we've had the for 4 years problem started 3 years ago and keeps getting worse. Axle stops are all in place. We've even welded the bracket to the axle and it breaks it off.
  11. I have 1994 Mack RB 688 dump truck, the torque rod continuously breaks the mount bolts on the rear axle, we've had it in 3 different chassis shops and no one can figure out why. Any Ideas?
  12. I have 1994 Mack, the torque rod continuously breaks the mount bolts on the rear axle, we've had it in 3 different chassis shops and no one can figure out why. Any Ideas?
  13. Looking for a tachometer cable for a 1989 Msck R690ST any leads?
×
×
  • Create New...