Jump to content

KKRT

Puppy Poster
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

1 Good

About KKRT

  • Rank
    First Gear

Profile Information

  • Location
    Washington DC
  • Interests
    Diesel Trucks

Previous Fields

  • Make
    CH
  • Model
    613
  • Year
    2004

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. TimberJack, Any update on pulling a load (power)? Plus anyone has idea an what to do to clear the lightening bolt, and the 1-4 code?
  2. Timberjack, A full documentation of the process, pictures, etc. will help the community (especially in the wiring and ECU department). Many have struggled with the ASET, and as these ASET trucks age and/or need engines, all in the community will benefit from the knowledge on installing earlier E7s to keep our trucks rolling. Other forums do such educational topic all the time: I will like to encourage any others with additional info, expertise to please chime in. Thanks in advance.
  3. Timberjack, Do you have pictures of how the 2003 harness plugs into the firewall? Or is does is just plug into the old slot for 2004 harness. Great info for 2004 CH ASET owners who may consider ETECH swap, backdating, etc.
  4. Teammates, I after lots of guessing and fan clutch replacement (expensive), it turned out to be a bad AC high pressure switch (picture - green switch). Fan works normal now, and only comes on when coolant gets hot. I appreciate the input from all.
  5. Macpro, I unplugged and checked the 3 connectors for the engine ECU. None of them have oil or antifreeze in them. Could a bad ground cause this fan problem?
  6. All electric. I put a new fan in the truck but I have the same problem: Fan continues to come on every 30 seconds even when AC is off.
  7. dcrow, Any updates on your performance module install?
  8. I have an ASET engine. How do you check for a faulty fan before doing an expensive replacement (buying a new one)?
  9. Team mates, I have this annoying problem a few mechanics have not been able to help me resolve. My cooling fan shuts down for about 30-45 seconds and comes right back on. In effect, you hear the cooling fan running all the time. Engine temp stays around 180 degrees. I have also changed the fan switch sensor on the back of the engine (coolant reservoir) still no change, fan continues to run. Any suggestions out there?
  10. Thanks folks, I definitely appreciate the info. I'll check into the performance module. If anyone else has got additional input, I'll appreciate it.
  11. I just joined the forum after purchasing a 2004 CH713 with an AC 427 engine. I pull 20+ ton trash trailers and this CH will not pull up hill like the other guys. Two questions to the Mack Team; 1. How can I delete the EGR to make it a regular E7 427?, and 2. How can I get more power to pull them hills? I know these topics may have been address in the past, but I will appreciate any feedback. Thanks
×
×
  • Create New...