mackrmodel686st

Puppy Poster
  • Content count

    25
  • Joined

  • Last visited

Everything posted by mackrmodel686st

  1. I've got a 2001 cx613 Mack vision that doesn't switch between defrost, floor, dash and mix. I've replaced the controls but didn't fix the problem. I don't see any burnt or melted wiring. Can anyone point me in the right direction on how to fix this issue?
  2. The ch613's we have are the same way, but I think the cx613's are electric.
  3. I've got a 2001 Mack cx613 that keeps burning out the headlight switch every few weeks. When it happens the headlights continue to work, but the tail lights, marker lights in the hood and center three clearance lights on the roof don't work. Also the dash lights go out too. I change the switch out and it works fine for a couple weeks, then the lights go out again. Can anyone point me in the right direction on how to cure this problem once and for all?
  4. There are two switches, one for the headlights and markers, one for the clearance lights.
  5. Why would you want to do something so silly? A camel back suspension will add about 1000 pounds to your truck and make it ride rough as hell.
  6. You wouldn't happen to have any pictures of what you did.
  7. It boils down to injectors, cam timing, bigger turbo, and computer programming. My boss had it done to one of our 350's and had it converted to a 427. It's expensive but can be done. It would almost be cheaper to find a used 427 and swap it out. Either way it's gonna cost you about 20 grand. As is, your truck has a good, reliable motor that will get decent fuel mileage, it's just gonna be a bit of a dog off the line, excuse the pun.
  8. Based on my experience, an e7 is an e7, as In all the same. The 300, 350, 427, and 460 are horsepower ratings. They have different injectors, turbos, and cam timing. Oil coolers can be either the cast-iron barrel type or the flat tin type, will have different filter brackets depending but both will work. The manifolds are the same, so are the valve covers, oil pans, flywheel housings and flywheels.
  9. All the e7 air clutches I've worked on at my shop need air to disengage the clutch and let the fan spin free. I have had one get stuck engaged even with shop air. I sprayed some pb blaster in the air fitting and around the clutch assembly and it freed up. Works fine now. Also check to make sure your air solenoid is working. The ones I deal with need 12v power to shut the air off and turn the fan on. I know it sounds backwards, but that how it works. Also, your computer may not be sending power to the solenoid, you can check that too.
  10. I have a 1980 r model with mack axles and a camel hump suspension. I'm gonna be grafting the rear frame from a 1999 ch mack for the air ride suspension onto the r model. I also have the mack axles from a 1993 ch mack to go under the air ride. My question is, will the differentials from the 1980 mack axles work in the 1993 housings? The r model has a maxidyne engine with a maxitorque twin stick trans and don't want to change the axle ratios.
  11. If it is a mack engine, it's most likely a 300 maxi-dyne. Was the most common engine they made back then. The company I work for has one, and used to have another one.
  12. The wires for the speedo sensor are on the back of the trans right by the yolk for the driveshaft.
  13. Have you tried shifting without the clutch? Sometimes trucks get used to being driven a certain way. Don't ask me why this happens, but I've seen with new trucks they run just fine either way at first. But after a while of driving them one way or the other they won't run right if you try to drive it differently. Same goes for using starting fluid, if you use it to much, they won't start without it event when it's hot out.
  14. I doubt its the jake as it doesnt function under 800 rpm or when you are on the throttle. The computer takes care of that for you. What rpm does your tach read when it does this. You could be hitting the Rev limiter.
  15. I have a 1999 mack ch613 daycab with a 427 engine and an eaton/fuller 10 speed trans. I am currently in the process of pulling the trans for the 5th time in a year because the bellhousing bolts keep loosening ans snapping off. The mounts at the trans are brand new and the one at the front of the motor seems to be fine. Why does this keep happening? I've used both the blue then the red loctite, yet this keeps happening. Is this a case of driver abuse or something else that I'm not seeing?
  16. They actually call the motor half a flywheel housing. Yes it's aluminum, been replaced with used ones on several occasions and been replaced with new at least once. As I said before, no motor issues, runs just fine. Plenty of power and no vibrations. Am currently replacing both the bell and flywheel housings. Mack doesn't make a steel flywheel housing, but we did find a steel bellhousing to replace the aluminum one. I don't think that is causing the problem because this has happened with two different trannys.the first one was a rockwell 10 speed, now has an eaton/fuller 10 speed. Both bolt up identical.
  17. We have done a few swaps like this and this is the only truck with issues.
  18. Was a swap and I'm not sure if the old one is still around, may have gone back as a core.
  19. As far as I know it didn't start happening till after a motor swap. It may have been before that as I don't know the whole history of the truck. No vibration complaints from the driver. Like I said previously, a dealership we work with is having the same issue with no ideas why.
  20. Both the motor side and trans side of the bell have previously been replaced with new ones and still keeps happening. I have a dealer that I've been talking to, they have a rental with the same problem and can't figure it out.
  21. There is no need for insults, I came here looking for honest help on my problem.
  22. I've made the suggestion of checking the nut behind the wheel, unfortunately it's the boss's brother.
  23. Bell to block, has 11R22.5 tires, same gear ratio as original trans, original axles. Clutch is like new.
  24. I have a 1980 R 686st with the camelback suspension under it, and the axles, bags and leafs from a 1996 CH 613. I guess my question is, can I adapt the air ride to the R model frame or do I have to graft the frame rails from the CH to the R model frame rails? I'm also going to stretch the frame a foot or two, once I get it done, I will post some before and after pics.
  25. Those pisc are great. It's too bad you have the fenders on, I'd kinda like to see how you shimmed the air ride mounts and the frame. The truck looks really good tho.