Jump to content

  •  

  • Welcome to BigMackTrucks.com

    Welcome to BigMackTrucks.com, the best resource on the Internet for Antique, Classic and Modern Mack Trucks!  

     

    Please login or register to take advantage of everything BMT has to offer.  Memberships are Free and offer many benefits:

     

    • Start new topics and reply to others
    • Subscribe to topics and forums to get automatic updates
    • Showcase your trucks in our Garage
    • Photo Gallery, Member Blogs and much more...
    • Add events to our community calendar
    • Create your own profile and make new friends
    • Customize your experience!
    • Mack Dealer and Corporate personnel can contact the ADMIN after registration for access to the Dealer Forums.

    If you are having trouble logging in or haven't received your validation email, you can post as a guest in the Guest Forum.


    login  register
    Guest Message by DevFuse
     

    Photo

    e7 427 excessive oil and water temp



    • Please log in to reply
    No replies to this topic

    #1 OFFLINE   dgk1

    dgk1

      Rookie

    • Puppy Poster
    • Pip
    • 3 posts
    • Location:va
    • Make:mack
    • Model:cx613
    • Year:2000

    Posted 07 January 2012 - 09:52 PM

    I have a 2000 cx 613 with etech 427. I just put a cam in it along with new rods,mains and oil pump. Also put a new head on it. I started it for the first time today and it has a rough idle and then smoothes out as you run it up to around 900- 1000 rpm. Figuring that's the valves need adjusting. I ran it for about 35-40 mins and the oil and water temp was almost at redline. What could cause this? What do i need to look for?




    0 user(s) are reading this topic

    0 members, 0 guests, 0 anonymous users