Jump to content

ETECH 410 won’t start or bleed up.


Recommended Posts

My 98 CH tipper has been static in the yard for 6 months but always fired when we needed to move it. Went to fire it the other day after I check fuses for no brake lights, then I check the fuse box under bonnet and blew the dust off with air and went to start and it fired straight away and run for a few minutes then slowly shutdown like out of fuel, started a few more times then would not fire. Checked tanks and they were half full, then cracked line to filters and pressurised tank and fuel came out. Primed it and would not become rigid so changed primer and and also found plastic holding return check valve open so I replaced this, and still primer not becoming rigid until I pressured lines, then after I bled them the primer again would not hold pressure....... would this be o rings or one inject o ring failing? 

Link to post
Share on other sites

Find out where that plastic you found in the primer pump is coming from. Had the personal experience of finding a bread bag in a guy’s tank. If it’s a clear bread bag it’s absolutely invisible when submerged in the fuel. 

Also, you need to crack injector lines while pumping the primer to move air out properly. The EUP has an open center that will allow fuel flow with the key off. On the older EUP you want to crack the line at the EUP, not in the head.

 

Edited by Mack Technician
Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...