Jump to content

Recommended Posts

I have a 2000 cx613 trying to do an Inframe but not sure what motor I have truck says to be E7-460 but could have been swapped. I can’t find anything on the motor telling me what it is. Any help would be appreciated 

vin 1M1AE07YEYW002545

also found these numbers on the block under the oil fill tube

950140

5537M 9272 6374

5DF57132-52EF-4645-99CE-067CF1BDF8D3.jpeg

Link to post
Share on other sites

Go in to your dealership with your vin and ask the parts guy to run off a copy listing the itemized parts breakdown. That’ll give you the option to buy dealership or aftermarket. Also get listing of muzzleloader kits. 

Rare chance you have a retrofit engine from a different vintage. It’s a pain in the butt to convert. The only engine better than yours is a 2002, and it won’t share computers. By 2003 it was an EGR engine and you’d never install that to a pre-3 emissions. Your truck is in the middle of the post-PLN V-Mac II 1998-1/2 and pre-2002 CCRS era. PLN has one pump. Take a side pics of the engines right side and post them. 

  • Thanks 1
Link to post
Share on other sites
Posted (edited)

That's a post 1998-1/2 and pre 2002 CCRS E-Tech. Low likelihood that it's a swapped engine, most likely original to the vin. Even if it was swapped it has the same internal base engine parts (for those years) as the original.  

Looks like somebody had a head start on your overhaul.... why did they stop?

Edited by Mack Technician
  • Thanks 1
Link to post
Share on other sites

Good to know thanks!! Yeah me and my brother have been working on it slowly I need to pull the cam and order parts just not sure what kit to get I was thinking the pai performance kit with the coated pistons and bearings and such 

Link to post
Share on other sites
Posted (edited)

Looks like there was no coolant in that! Straight water probably killed it  ,to bad ! It pays to run antifreeze and a change the coolant filter once and a while!

Check your counter bores closely!

Edited by fjh
  • Like 1
Link to post
Share on other sites

Ah yup that’s true of that era still looks to had no coolant! Straight water is not the best for them blocks. Hope you didn’t hit the crank jacking them liners out!😢

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...