Jump to content

Engine Coolant Overheat::: A/C NOT Working


Recommended Posts

1 truck  2 issues, First the Engine Coolant runs hot loaded up hill this is small hills as we are in flat land they are also short 1/4  to 1/2 mile at most,  gets up to 230-240 with all alarms going. the Radiator is clean inside and out, we flushed it and run a borscope down the Radiator,  and it looked good all the way down, told the thermostat was just replaced, and water pump was replaced. Fan looks good and is coming on and off around the 205 aera. Only coolant it looses is out the overfill when it gets hot, also has been pressure tested and holds ok. Have replaced the cap as well. 

The second problem with same truck is the A/C, When it is first turned on it starts to get cold and then stops. Then the clutch starts to cycle about 6-10 sec on and 20-40 off.  The high side never realy goes above 130 and the low side drops from 40 to almost 0 instantly re: 5psi. It has been vacuumed down and recharged using a good modren RRR machine. this was done 3 times just to make sure we had a proper starting point.  This is not an APADS system.  I only see 2 PRESSURE switchs in the A/C system under the hood. One is in the dryer and the other is in the same line just before the dryer.  I have disconnected these switchs individually and it makes no differance the clutch still cycle's on and off, I have also jumped these switches on the harness side and it still makes no diff clutch still cycles on/off. Likewise the fan does not come on or off when  I unplug or jump these switches on the harness side. I would think one of these is a fan switch ?.  
So because the  A/C fan switch is not working I was wondering if that is affecting the heating issue. So I need to figure out why the coolant is over heating , why the A/C fan switch is not working. And why the A/C does not work. Likewise why would the A/C keep cycling even when the pressure switches are unpluged and not jumped.  The Truck is a 2001 CH613 ser# 1M1AA18Y11W139540.  I do not have a Mack Dealer in my aera on the Border of Northwest North Dakota. So any ideas where to start would be helpful. Thanks. 
  
 

Link to post
Share on other sites

You will also have a freeze switch in the dash core to keep it from going below 32 degrees and becoming an ice block of frozen condensate. When the condensate freeze occurs you see some of these same symptoms....Good operation for a short period......then freeze up.........then.....Low air flow from vents, short cycles, low R134A pressures with little fluctuation because the overall system is cold and not collecting heat, no engine fan reaction because pressure won’t rise high enough to trip fan.  

Your high pressure AC switch being unplugged should cause fan to come on and stay on with that set-up. Story makes no sense there because you said normal cooling cycle activations are good? I’ll look at my schematic Monday, unless someone else knows the answer. 

  • Like 1
Link to post
Share on other sites

If you run for long time on flat ground, does it over heat? The symptoms are similar to my VW diesel when I a bad head gasket. I tried all the remedies you mentioned but with no success. The coolant system gets a air bound from the gases.

Let us know what you find.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...