Jump to content

Recommended Posts

New owner of a (I know, dreaded) MS200P. 1991, Allison, 120k miles, flatbed. It’s my overkill firewood hauler. Am looking at converting to dump. I’ve always had a liking for big ol’ trucks. Previously owned a 70s M35A2(Duece) and M792(Gamagoat.) still have a ‘75 IH Loadstar 1600 C/C. 

Drove the Mack about 250 miles home so I got fairly acquainted with it. Did have a warning light come on in the dash that I cannot figure out. It only came on when I was stopped or rolling slow a couple times. And the only other issue I’ve had is the gear selector is a MF to get to move into gear forward or reverse. Took the shifter loose and checked it. Doesn’t appear to have anything binding. Interlock works fine. Cable not noticeably bound. Anyone with ideas? 

Share this post


Link to post
Share on other sites

Thank you. I don’t know what I’ll need for it yet if anything. I’m sure something will come up. 

Share this post


Link to post
Share on other sites

Rich, would you happen to have an automatic shift cable or part number for mine? It has the Allison AT545. Thanks, Marc

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...