Jump to content
Sign in to follow this  
c-mac

06 chn Asset “grey” motor fan clutch

Recommended Posts

Wondering if someone could post a diagram for the fan clutch? It looks like at some point a belt broke and tore the connector off the engine harness. I guess the clutch finally got tired of staying engaged at all times. I’ve replaced the clutch, now thinking I can hard wire the new clutch or try and obtain a new connector but the wires are all the same color with numbers on them. The boss don’t want to by a harness for one connector. Thanks

Share this post


Link to post
Share on other sites

I know this is a little old, but have you fixed it? I assume the engine is an "AC" engine?

If so I have a diagram at the shop I can send you.

Share this post


Link to post
Share on other sites

Yes it has a/c the new fan clutch is on at all times with the harness to the clutch disconnected. I’d really like to see the diagram if it shows wire number and numerical pin placement 

Edited by c-mac

Share this post


Link to post
Share on other sites
On 9/3/2019 at 3:11 PM, c-mac said:

Yes it has a/c the new fan clutch is on at all times with the harness to the clutch disconnected. I’d really like to see the diagram if it shows wire number and numerical pin placement 

Sorry for the delay, crazy busy lately. I'll get that for you tomorrow!

Hopefully I can find it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...