Jump to content
R.E.D

Mack cv bad fuel pump

Recommended Posts

Good Find RED!

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, fjh said:

Good Find RED!

I'm surprised truck ran at all with that kind of pump failure!

Share this post


Link to post
Share on other sites

Well, that's ugggly. 

Recent machine work performed by Bucky the beaver.

  • Haha 1

Share this post


Link to post
Share on other sites

Hello fellas.

Quick update.Since replacing fuel pump truck has gained about 0.3 mpg .I guess the fuel pump is one of those things we have to throw a gauge in once in a while to make sure we are up to spec on pressure.for a sec I couldn't believe it but I started noticing that I could get a couple of extra loads with the same amount of fuel .😁

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

Yup I would have thought you would have had more poor starting symptoms with a pump that bad! the loosing prime thing happens more often than a low power complaint!

We had the loss of prime thing happen the last week ! We checked ALL the normal things  with no luck pressure was ok but fluctuating some so we changed out the pump!

Once the pump changed ,ALSO no luck we were stumped ! The truck would run after cranking for ever to get it to start  If  u turned it off it would not start a minute later!   reminded me of an MP engine with bad cups ! So I checked The fuel  return fuel was full of bubbles just foam The whole time since these engines have been around I have NEVER seen this! So  rolled the dice and pull the injectors had em tested!  4 would Not pop test AT ALL the guys gauge maxed out the other 2 were just slobbering fuel it was amazing the engine ran at  all ! funny thing is it really didn't sound bad ! Anyway just another Shit happens occurrence Kind like your fuel pump ! Again Good find on the pump Red ! 

Edited by fjh

Share this post


Link to post
Share on other sites
6 hours ago, fjh said:

Yup I would have thought you would have had more poor starting symptoms with a pump that bad! the loosing prime thing happens more often than a low power complaint!

We had the loss of prime thing happen the last week ! We checked ALL the normal things  with no luck pressure was ok but fluctuating some so we changed out the pump!

Once the pump changed ,ALSO no luck we were stumped ! The truck would run after cranking for ever to get it to start  If  u turned it off it would not start a minute later!   reminded me of an MP engine with bad cups ! So I checked The fuel  return fuel was full of bubbles just foam The whole time since these engines have been around I have NEVER seen this! So  rolled the dice and pull the injectors had em tested!  4 would Not pop test AT ALL the guys gauge maxed out the other 2 were just slobbering fuel it was amazing the engine ran at  all ! funny thing is it really didn't sound bad ! Anyway just another Shit happens occurrence Kind like your fuel pump ! Again Good find on the pump Red ! 

I did run into hard starting situation but for the remainder of the week I would pump the hand primer until hard and it would crank and studder.i could not have the one truck down that week and anyway the pump was not in town.i was Lucky no shavings got thru the fuel filter otherwise all the injectors would have been FUBAR.

and thanks again to all of you who take the time to help a bulldog when it's sick.😁

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...