Jump to content

Recommended Posts

Little history on truck, new engine wiring harness that's junk, 3 ECMs swapped out. So i figured out most of the other issue by myself. Just having problems trying to diagnosing these last 2 codes before replacing the engine harness again. New pressure differential sensor, new intake sensor. EGR valve is getting voltage, sensor lines for EGR sensor are clean. BTW, I'm new here. so any help would be greatly appreciate!!   

Share this post


Link to post
Share on other sites

Replacing engine harness fixed all my issue that i was having with truck. being a month out of warranty sucked. 

Share this post


Link to post
Share on other sites

Perfect Timing for the Volvo Guys!😡 Volvo Wins!  You Loose Thats how  the game is played! And that's how they make  money!

Share this post


Link to post
Share on other sites
On 9/23/2019 at 9:58 AM, fjh said:

Perfect Timing for the Volvo Guys!😡 Volvo Wins!  You Loose Thats how  the game is played! And that's how they make  money!

yeah you right

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...