Jump to content
Sign in to follow this  

Recommended Posts

got a 2006 mack LE 613 and just replaced air dyer and compressor. if you start the truck up it wont build air. unless you floor it. but only the primary tank slowly stats to build, get to 30 psi and wont build anymore. im thinking governor. any ideas

Share this post


Link to post
Share on other sites

You have a line leak between the compressor and the dryer. The reason you can't find it is because it spontaneously leaks out of the small trapped column and is gone before your ear is on it. When running you can't hear the leak well. The leak is small enough to allow a little bit of air to remain and pressurize in the line, enough to create 30 PSI at a rev, but that's it. Soap the line while it's running at high rev and before the line gets really hot. Since you have a check valve at the air dryer there is not going to be backflow from the system to sustain the leak with engine off, so it may only be found running. Good Luck!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...